summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-17 09:22:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-17 09:22:10 +0200
commit8bcc5907d4db1c74d70718e8289889eaf3a498a3 (patch)
tree4f50ffc0f229222f86ed5671db5f922a99362324
parentdev-python/Rx: Remove old (diff)
downloadgentoo-8bcc5907d4db1c74d70718e8289889eaf3a498a3.tar.gz
gentoo-8bcc5907d4db1c74d70718e8289889eaf3a498a3.tar.bz2
gentoo-8bcc5907d4db1c74d70718e8289889eaf3a498a3.zip
dev-python/PyUtilib: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyUtilib/Manifest1
-rw-r--r--dev-python/PyUtilib/PyUtilib-5.7.2.ebuild55
-rw-r--r--dev-python/PyUtilib/files/pyutilib-5.6.5-tests.patch35
3 files changed, 0 insertions, 91 deletions
diff --git a/dev-python/PyUtilib/Manifest b/dev-python/PyUtilib/Manifest
index a1658209491d..f11f0827d683 100644
--- a/dev-python/PyUtilib/Manifest
+++ b/dev-python/PyUtilib/Manifest
@@ -1,2 +1 @@
-DIST PyUtilib-5.7.2.tar.gz 1566034 BLAKE2B 913c6576b39f14c19e2e633c36ade33fe812c77a37374c7c14d2fb4384ca38f68efd55209d70e96d9a78fea2fcf1cf83423680d0787da2d03cab88e59a208b96 SHA512 d9d7d890cdb524bb055885354784f2af01967164ce88cf3b144ccffb0a855ef34243fd518c58193517ecfc50f3c2e3ca333f026951c1ab0b38ce181ecf9e7750
DIST PyUtilib-6.0.0.tar.gz 1569916 BLAKE2B ee4085b597e928c5d6602b647f122c562f2e05dcaf300217cea9c5bc652f6acb5dbe5a075cbbbc1b81497987ab5c658f86cc3e44e16cae02a37d546b2e925a9b SHA512 7841a84ee8d66d2d7af3db810e4d787030acbd8e3e81c3f61251ea160931feddeab6f4d205977a411964359f1cb7e7e59e846593c113093e01c48b81784f7477
diff --git a/dev-python/PyUtilib/PyUtilib-5.7.2.ebuild b/dev-python/PyUtilib/PyUtilib-5.7.2.ebuild
deleted file mode 100644
index e1418c3cb92e..000000000000
--- a/dev-python/PyUtilib/PyUtilib-5.7.2.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..10} )
-DISTUTILS_IN_SOURCE_BUILD=1
-
-inherit distutils-r1
-
-DESCRIPTION="A collection of Python utilities"
-HOMEPAGE="https://github.com/PyUtilib/pyutilib"
-SRC_URI="https://github.com/${PN}/${PN,,}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN,,}-${PV}"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-BDEPEND="${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}/pyutilib-5.6.5-tests.patch"
-)
-
-python_prepare_all() {
- # remove some tests that are completely broken
- rm pyutilib/component/app/tests/test_simple.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing --via-root
-
- local -x PYTHONPATH="${PWD}:${TEST_DIR}/lib" \
- COLUMNS=80
-
- nosetests -v --with-xunit --xunit-file=TEST-pyutilib.xml pyutilib || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- find "${ED}" -name '*.pth' -delete || die
-}
-
-python_install() {
- distutils-r1_python_install
-}
diff --git a/dev-python/PyUtilib/files/pyutilib-5.6.5-tests.patch b/dev-python/PyUtilib/files/pyutilib-5.6.5-tests.patch
deleted file mode 100644
index 780c586759af..000000000000
--- a/dev-python/PyUtilib/files/pyutilib-5.6.5-tests.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff --git a/pyutilib/dev/entry_point.py b/pyutilib/dev/entry_point.py
-index e571cc7..e0200e9 100644
---- a/pyutilib/dev/entry_point.py
-+++ b/pyutilib/dev/entry_point.py
-@@ -23,7 +23,8 @@ def run_entry_point(package, script, args=[], **kwds):
- script = str(script)
- assert type(args) is list
- cmdLine \
-- = "import pkg_resources,sys; "\
-+ = "import pkg_resources,sys,os; "\
-+ "pkg_resources.fixup_namespace_packages(os.path.join(os.getcwd(),'build')); "\
- "sys.argv=%r; "\
- "sys.exit(pkg_resources.load_entry_point(%r,'console_scripts',%r)())" \
- % ( [script]+args, package, script )
-diff --git a/pyutilib/enum/tests/test_enum.py b/pyutilib/enum/tests/test_enum.py
-index 52451ef..66313f4 100755
---- a/pyutilib/enum/tests/test_enum.py
-+++ b/pyutilib/enum/tests/test_enum.py
-@@ -11,7 +11,7 @@
- """ Unit test for ‘enum’ module.
- """
-
--import unittest
-+import unittest, sys
-
- import pyutilib.enum.enum as enum
-
-@@ -355,6 +355,7 @@ class Test_EnumValue(unittest.TestCase):
- for other_value in self.other_values:
- self.assertNotEqual(test_value, other_value)
-
-+ @unittest.skipIf(sys.hexversion > 0x03040000, "can't compare int and tuple on python3")
- def test_sequence_other_values(self):
- # An EnumValue should compare sequentially to other values.
- test_value = enum.EnumValue(self.SimpleEnum, 0, 'test')