summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-01-01 17:18:13 +0100
committerDavid Seifert <soap@gentoo.org>2023-01-01 17:18:13 +0100
commit8bda24a631d058a74942a8eca37972915058123a (patch)
tree998f9d0dfec234ea7e0e2596fe8e1468401b34c1
parentdev-vcs/gitg: update EAPI 7 -> 8 (diff)
downloadgentoo-8bda24a6.tar.gz
gentoo-8bda24a6.tar.bz2
gentoo-8bda24a6.zip
x11-misc/meteo: move vala deps to BDEPEND
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--x11-misc/meteo/meteo-0.9.9.1-r2.ebuild (renamed from x11-misc/meteo/meteo-0.9.9.1-r1.ebuild)17
1 files changed, 8 insertions, 9 deletions
diff --git a/x11-misc/meteo/meteo-0.9.9.1-r1.ebuild b/x11-misc/meteo/meteo-0.9.9.1-r2.ebuild
index b68fc55cee62..d3cc18f55cd5 100644
--- a/x11-misc/meteo/meteo-0.9.9.1-r1.ebuild
+++ b/x11-misc/meteo/meteo-0.9.9.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit gnome2-utils meson python-any-r1 vala xdg
DESCRIPTION="Forecast application using OpenWeatherMap API"
@@ -13,9 +13,11 @@ SRC_URI="https://gitlab.com/bitseater/meteo/-/archive/${PV}/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64"
+# One test needs network (#828052), the other simply checks desktop file
+# validation, that we also test with our QA tests
+RESTRICT="test"
DEPEND="
- $(vala_depend)
dev-libs/libayatana-appindicator:0
dev-libs/glib:2
dev-libs/json-glib
@@ -31,15 +33,12 @@ BDEPEND="${PYTHON_DEPS}
dev-libs/appstream-glib
dev-util/intltool
virtual/pkgconfig
+ $(vala_depend)
"
-# One test needs network (#828052), the other simply checks desktop file
-# validation, that we also test with our QA tests
-RESTRICT="test"
-
-src_prepare() {
- default
+src_configure() {
vala_setup
+ meson_src_configure
}
src_install() {