summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-15 00:22:54 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-15 00:22:54 -0500
commit8bf053bdc69a35944d4e231330ad579d27a99eaf (patch)
tree131ffe9c72a5b39c626ca3c601d4ea5b11600779
parentdev-python/oslo-db: adding python34 (diff)
downloadgentoo-8bf053bdc69a35944d4e231330ad579d27a99eaf.tar.gz
gentoo-8bf053bdc69a35944d4e231330ad579d27a99eaf.tar.bz2
gentoo-8bf053bdc69a35944d4e231330ad579d27a99eaf.zip
dev-python/python-editor: adding for new alembic
Package-Manager: portage-2.2.20.1
-rw-r--r--dev-python/python-editor/Manifest1
-rw-r--r--dev-python/python-editor/metadata.xml10
-rw-r--r--dev-python/python-editor/python-editor-0.4.ebuild20
3 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/python-editor/Manifest b/dev-python/python-editor/Manifest
new file mode 100644
index 000000000000..6605b8a5ba9f
--- /dev/null
+++ b/dev-python/python-editor/Manifest
@@ -0,0 +1 @@
+DIST python-editor-0.4.tar.gz 6516 SHA256 4421a7116bf3af957266f225bc79ad25b92839cc7974c8335bba5a6582edd3bf SHA512 f1fd4660e67e8299a6f9183e85a1e213e1156542d84eae6644e4f42e5e2804f813857ee50bd8833728b320415ee6f2be5df4ca69acb10a709f20d2306eb5e7ad WHIRLPOOL 2c68e5749bf7955315888a3bed45d3f3b68ef575804342e1391269a9f6f05ddce43242dc988dd29e805f9c165e06731b857238bdebd94e2e5c1f2f7181da24d9
diff --git a/dev-python/python-editor/metadata.xml b/dev-python/python-editor/metadata.xml
new file mode 100644
index 000000000000..d5dfd322223c
--- /dev/null
+++ b/dev-python/python-editor/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/python-editor/python-editor-0.4.ebuild b/dev-python/python-editor/python-editor-0.4.ebuild
new file mode 100644
index 000000000000..b747843a72f6
--- /dev/null
+++ b/dev-python/python-editor/python-editor-0.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Programmatically open an editor, capture the result."
+HOMEPAGE="https://github.com/fmoo/python-editor"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"