summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Rothenpieler <btbn@btbn.de>2020-07-24 21:01:18 +0200
committerAlexys Jacob <ultrabug@gentoo.org>2020-10-21 14:57:35 +0200
commit8c24ca428ecf17400cea4e8f36fb46aaf08194e5 (patch)
tree8fd4d1e9eab8156935110676fb015d4c4e3b74fa
parentsys-apps/opal-utils: add noexec devtmpfs patch for opal-prd (diff)
downloadgentoo-8c24ca428ecf17400cea4e8f36fb46aaf08194e5.tar.gz
gentoo-8c24ca428ecf17400cea4e8f36fb46aaf08194e5.tar.bz2
gentoo-8c24ca428ecf17400cea4e8f36fb46aaf08194e5.zip
sys-cluster/libqb: bump for 2.0.1
Signed-off-by: Timo Rothenpieler <btbn@btbn.de> Closes: https://github.com/gentoo/gentoo/pull/16803 Signed-off-by: Alexys Jacob <ultrabug@gentoo.org>
-rw-r--r--sys-cluster/libqb/Manifest1
-rw-r--r--sys-cluster/libqb/libqb-2.0.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/sys-cluster/libqb/Manifest b/sys-cluster/libqb/Manifest
index 98f98acbf09a..e04722e9ba95 100644
--- a/sys-cluster/libqb/Manifest
+++ b/sys-cluster/libqb/Manifest
@@ -1,3 +1,4 @@
DIST libqb-0.17.2.tar.xz 373540 BLAKE2B b9d751fca21cc25798a24207740b14722502cbb918cc652cd33b0159a9bd1254a8a64bc73684ae3274a2cf346db5b19924cf010ba487f4c6a9a5f9deade792c4 SHA512 9c6dce7d18aa4da31594faecd0ea2737c2beefa749290094f733fe89ac40f094ec6409f310c534b8144d500e8c204c328386eaf1029995698d7019c014433443
DIST libqb-1.0.5.tar.xz 488516 BLAKE2B 96f61ce681d0c259e8df38f35c04349ab3b1199f62c2311d60c6f229bf15e8f62825c965a4847cbda4701119fc7ae3c68cc3a7187f927f8ddf7496cf1931c7c2 SHA512 a695bc4c913a32d47535cb2d8812f14a39732cae32651521a8f7b6d05c4202bfc28a477c88875bbfbe1a0238cd33f1fe64f2d2217b0c27cf11acf7233fc2cbdf
DIST libqb-1.9.0.tar.gz 225147 BLAKE2B d8200d5eec8c05a18675de585e2f85694d3d062d82afca38c421859e3e0287d1691fe9726a75d3726afc58a94765f6a201f8fb51bf1ed25c1cfeaeb326e6f6d0 SHA512 9bdf2087f610a7a02b976312d60391e1c53ebd3f36a897cdc3fcf818f666f772d63386b52bd11ed4e5ea52fa4775231ab7125359a270451f925b3821d9b8e3ee
+DIST libqb-2.0.1.tar.xz 480516 BLAKE2B 402ca20f16a232497c9a363c557556bbdcfffff5d0f075898bf4008bb51b30771f284c29b64421be1dae8215e153b8978ac06c9bd10f3e5e23632b597549d2c7 SHA512 6d989d30b381253c7d7c4ff1e6400ad3445b92184906c859f10d6352dd604a309d7e2d9c8298d8b8d59a0e884e2d821608a39f043db7e96db2118a867ef57672
diff --git a/sys-cluster/libqb/libqb-2.0.1.ebuild b/sys-cluster/libqb/libqb-2.0.1.ebuild
new file mode 100644
index 000000000000..385c29d12209
--- /dev/null
+++ b/sys-cluster/libqb/libqb-2.0.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Library providing high performance logging, tracing, ipc, and poll"
+HOMEPAGE="https://github.com/ClusterLabs/libqb"
+SRC_URI="https://github.com/ClusterLabs/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/100"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug doc examples systemd test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-libs/glib:2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/xz-utils
+ test? ( dev-libs/check )
+ doc? (
+ app-doc/doxygen[dot]
+ )"
+
+DOCS=( ChangeLog README.markdown )
+
+src_prepare() {
+ default
+
+ # Skip installation of text documents without value
+ sed -e '/dist_doc_DATA/d' -i Makefile.am || die
+
+ # Do not append version suffix "-yank"
+ sed 's|1-yank|1|' -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable systemd systemd-journal) \
+ $(use_enable debug)
+}
+
+src_compile() {
+ default
+ use doc && emake doxygen
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*.c
+ fi
+
+ use doc && HTML_DOCS=("docs/html/.")
+ einstalldocs
+
+ find "${D}" -name '*.la' -delete || die
+}