summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-08-18 12:40:44 -0400
committerMatt Turner <mattst88@gentoo.org>2023-08-18 12:40:49 -0400
commit8c3eae5f361988489a20982d41869ee2f95009de (patch)
tree2d09e1be530c5e1ad61a073d0bcd52cfdef6fd4d
parentdev-ruby/pairing_heap: new package, add 3.0.1 (diff)
downloadgentoo-8c3eae5f361988489a20982d41869ee2f95009de.tar.gz
gentoo-8c3eae5f361988489a20982d41869ee2f95009de.tar.bz2
gentoo-8c3eae5f361988489a20982d41869ee2f95009de.zip
x11-libs/libxcb: Fix dependency on xcb-proto
Closes: https://bugs.gentoo.org/912403 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-libs/libxcb/libxcb-1.16.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/x11-libs/libxcb/libxcb-1.16.ebuild b/x11-libs/libxcb/libxcb-1.16.ebuild
index 398a90536147..68b8c003f7a7 100644
--- a/x11-libs/libxcb/libxcb-1.16.ebuild
+++ b/x11-libs/libxcb/libxcb-1.16.ebuild
@@ -26,19 +26,19 @@ RDEPEND="
"
DEPEND="${RDEPEND}
x11-base/xorg-proto
- >=x11-base/xcb-proto-1.15.2
+ >=x11-base/xcb-proto-1.16.0
elibc_Darwin? ( dev-libs/libpthread-stubs )
test? ( dev-libs/check[${MULTILIB_USEDEP}] )
"
# Note: ${PYTHON_USEDEP} needs to go verbatim
BDEPEND="${PYTHON_DEPS}
- $(python_gen_any_dep '>=x11-base/xcb-proto-1.15[${PYTHON_USEDEP}]')
+ $(python_gen_any_dep '>=x11-base/xcb-proto-1.16.0[${PYTHON_USEDEP}]')
doc? ( app-doc/doxygen[dot] )
test? ( dev-libs/libxslt )
"
python_check_deps() {
- python_has_version ">=x11-base/xcb-proto-1.15[${PYTHON_USEDEP}]"
+ python_has_version ">=x11-base/xcb-proto-1.16.0[${PYTHON_USEDEP}]"
}
pkg_setup() {