summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-09-07 10:22:20 +0100
committerMarek Szuba <marecki@gentoo.org>2023-09-07 10:27:46 +0100
commit8c44d74c8d73fe8b62482574516f8e2e292d6ed4 (patch)
treeff093432c1eba6ba3f2478e03a16242ef9e4fca6
parentsys-apps/fwupd: add 1.9.5, drop 1.9.4 (diff)
downloadgentoo-8c44d74c8d73fe8b62482574516f8e2e292d6ed4.tar.gz
gentoo-8c44d74c8d73fe8b62482574516f8e2e292d6ed4.tar.bz2
gentoo-8c44d74c8d73fe8b62482574516f8e2e292d6ed4.zip
net-p2p/syncthing: add 1.24.0
Now with go-1.21 support. Standing by for 1.22 breakage in 3..2..1... Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-1.24.0.ebuild112
2 files changed, 113 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index 3bcd12763d70..7679c8cc09f2 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1,2 +1,3 @@
DIST syncthing-1.23.6.tar.gz 14213659 BLAKE2B ef4f1a8bbf5bce6c7bc9bf80f55c875b5edfd5c10481676ddff9b1579afc518723a28d83424e62a178192f795b30526eca912a3e0d20be1901b065c431acf139 SHA512 32162bcf1677015d3359a141968c9e3544c8bd631905489a11bf79f45fa4ae442e8dc0f24c19c2b55defd88b3d5b56ae35d352aac9c09f6b82c50fd8b27fc796
DIST syncthing-1.23.7.tar.gz 14314457 BLAKE2B 61efe4119617d8f63208b6ff579b5008580f3fb33b88d70fcab056cbe505950f0c71050a5e90213aad651b1efdb55bd45eefbcfd0f285a2e9e3b8c2e0ea569e9 SHA512 c52a0e80eb572b2f59b0be2222244ded68e8807ad6d65ecb9b94efa0eaae9c80fcae42e28665b0d0f95aa1018553fdab95f5d52a5dbab8ec700206b5644de28e
+DIST syncthing-1.24.0.tar.gz 18625515 BLAKE2B aeff0ab43fca0d6f440e6ccacb1a947e22131d625d8600eebaf9cc285a3ed51ab52cd9f13e64be79e290ba07d6181aafe5176922cf01d24ec65cc0882d1d7a61 SHA512 bc53ee04b3454642606047d2009fb9adaafd509d0a4e52a4b6e57565bf502615bfcbc29e15b30733ee8eace62685b00a784347f63c2986ccf90b70631f858908
diff --git a/net-p2p/syncthing/syncthing-1.24.0.ebuild b/net-p2p/syncthing/syncthing-1.24.0.ebuild
new file mode 100644
index 000000000000..d8e3bf08df7a
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-1.24.0.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop go-module systemd xdg-utils
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${PN}-source-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~x86"
+IUSE="selinux tools"
+
+RDEPEND="acct-group/syncthing
+ acct-user/syncthing
+ tools? ( >=acct-user/stdiscosrv-1
+ >=acct-user/strelaysrv-1 )
+ selinux? ( sec-policy/selinux-syncthing )"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+ "${FILESDIR}"/${PN}-1.18.4-tool_users.patch
+ "${FILESDIR}"/${PN}-1.23.2-tests_race.patch
+)
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ # Bug #679280
+ xdg_environment_reset
+
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/stdiscosrv|' \
+ cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service \
+ || die
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+}
+
+src_compile() {
+ GOARCH= go run build.go -version "v${PV}" -no-upgrade -build-out=bin/ \
+ ${GOARCH:+-goarch="${GOARCH}"} \
+ build $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ local icon_size
+
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+
+ domenu etc/linux-desktop/*.desktop
+ for icon_size in 32 64 128 256 512; do
+ newicon -s ${icon_size} assets/logo-${icon_size}.png ${PN}.png
+ done
+ newicon -s scalable assets/logo-only.svg ${PN}.svg
+
+ if use tools; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+ fi
+
+ systemd_dounit etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd-r2 ${PN}
+
+ keepdir /var/log/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ if use tools; then
+ systemd_dounit cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service
+ newconfd "${FILESDIR}"/stdiscosrv.confd stdiscosrv
+ newinitd "${FILESDIR}"/stdiscosrv.initd-r1 stdiscosrv
+
+ systemd_dounit cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}"/strelaysrv.confd strelaysrv
+ newinitd "${FILESDIR}"/strelaysrv.initd-r1 strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/stdiscosrv.logrotate strelaysrv
+ newins "${FILESDIR}"/strelaysrv.logrotate strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}