summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-29 13:24:22 +0100
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-12-29 13:42:21 +0100
commit8c45758b17cb4be5d14ed3b8435dd206bdb7f675 (patch)
tree8c682e6d9b95c752729217ac53ec65b5cea0ec8e
parentdev-python/jupyter_server: add version 1.13.1 (diff)
downloadgentoo-8c45758b.tar.gz
gentoo-8c45758b.tar.bz2
gentoo-8c45758b.zip
dev-python/jupyter_core: add version 4.9.1
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--dev-python/jupyter_core/Manifest1
-rw-r--r--dev-python/jupyter_core/jupyter_core-4.9.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/jupyter_core/Manifest b/dev-python/jupyter_core/Manifest
index 215774878a84..1a4ad534107b 100644
--- a/dev-python/jupyter_core/Manifest
+++ b/dev-python/jupyter_core/Manifest
@@ -1 +1,2 @@
DIST jupyter_core-4.8.1.tar.gz 73579 BLAKE2B d5dcc89d948fa52f4a1b7c210585e9e5657004a431a4d177d7393d8283a9be86117e2c2452e4381399d1f479ae7b9ec4c5f891d09dd99c81768a64b69d8b182a SHA512 774612652537f46f486c0ae4157053463debcdc079d5e732865c729ef7fbab5f0d1b8da5d4e7cc1eda3a80250b43877d8f75889fa86330f951c61e3f8a7a29e2
+DIST jupyter_core-4.9.1.tar.gz 74787 BLAKE2B 3c902063c4d2819c8254eca87a64d922c3d1e408fc22e96d03765a8bb0fe644a9aafaccf3db106841becf307ffe47c9fcb723cad611833b5fcbe79e812ea2445 SHA512 3a176271e073448e3a15a69d51558486775abebec051e141594fe0d2859d9a0fc5cadbf6857764de6d1ec746f03d9d22419c91f97015d4ff6694626f455df773
diff --git a/dev-python/jupyter_core/jupyter_core-4.9.1.ebuild b/dev-python/jupyter_core/jupyter_core-4.9.1.ebuild
new file mode 100644
index 000000000000..a854289d7d62
--- /dev/null
+++ b/dev-python/jupyter_core/jupyter_core-4.9.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Core common functionality of Jupyter projects"
+HOMEPAGE="https://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="dev-python/traitlets[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ >=dev-python/ipython-4.0.1[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinxcontrib-github-alt
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails if jupyter is not in system sitedir
+ # (PYTHONPATH is insufficient)
+ jupyter_core/tests/test_command.py::test_not_on_path
+ jupyter_core/tests/test_command.py::test_path_priority
+ # assert '/usr/local/share/jupyter' == '/usr/share/jupyter'
+ jupyter_core/tests/test_paths.py::test_jupyter_path_user_site
+ jupyter_core/tests/test_paths.py::test_jupyter_path_no_user_site
+ # TODO
+ jupyter_core/tests/test_paths.py::test_jupyter_path_prefer_env
+)