summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2019-12-06 00:50:36 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2019-12-06 00:50:54 +0100
commit8c484e328c2f74cc94eb1623ea112813013013ab (patch)
treed8b3f1ca0b4230fe344dc297e1d9d5fdf9b28961
parentpackage.mask: unmask trackma, no longer needs py2 (diff)
downloadgentoo-8c484e32.tar.gz
gentoo-8c484e32.tar.bz2
gentoo-8c484e32.zip
dev-tex/dot2tex: 2.11.3 bump
Ebuild update and add python 3 support Closes: https://bugs.gentoo.org/699956 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
-rw-r--r--dev-tex/dot2tex/Manifest1
-rw-r--r--dev-tex/dot2tex/dot2tex-2.11.3.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
index 017a9d34e246..132a09b856fc 100644
--- a/dev-tex/dot2tex/Manifest
+++ b/dev-tex/dot2tex/Manifest
@@ -1 +1,2 @@
+DIST dot2tex-2.11.3.tar.gz 664750 BLAKE2B 9c7effeca0d71810ce37e126df9e7df2b9df19be41393916c85e49df0dc116f42e58a2b29cce9e2bac700fa00859c63c1a4a8c41c70a9db96a5fc210960f463b SHA512 1595299811461b18cff490a8a56c0215f46989dd4a46fa087b455c717ed5d5f7a5782d04acaa3e4567b4e348bca866d5f24d21663012c4cd813445804ef6f714
DIST dot2tex-2.9.0.tar.gz 663372 BLAKE2B 807093c5bd7304a6c315568e69c8c8387a377a8aa47790d558feb84036ca6ce2d00534823254a50af9852206d0e27b2e15f2a8ba0e8333e2bb8b20a983947e74 SHA512 97ba9983643254d5a3034d2fc8c454c445849ac546bd285676b854e20c8aae9a25d61e73632717da1562541ce9b3a4ae8aa4daa29e33f78105e28a34b5ebae5d
diff --git a/dev-tex/dot2tex/dot2tex-2.11.3.ebuild b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
new file mode 100644
index 000000000000..2ea47959d682
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.11.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7})
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
+SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dodoc -r docs/_build/html
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}