summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-30 13:46:40 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-10-30 13:46:40 +0100
commit8c657857b6f569db1b8ffe5765dd9707610ae9da (patch)
treee1b99008d37776da177d0198342eb5002fbc3439
parentmedia-libs/kvazaar: Initial import. Ebuild by me. (diff)
downloadgentoo-8c657857b6f569db1b8ffe5765dd9707610ae9da.tar.gz
gentoo-8c657857b6f569db1b8ffe5765dd9707610ae9da.tar.bz2
gentoo-8c657857b6f569db1b8ffe5765dd9707610ae9da.zip
media-video/ffmpeg: Add kvazaar useflag.
Package-Manager: portage-2.2.23
-rw-r--r--media-video/ffmpeg/ffmpeg-9999.ebuild7
-rw-r--r--media-video/ffmpeg/metadata.xml1
2 files changed, 5 insertions, 3 deletions
diff --git a/media-video/ffmpeg/ffmpeg-9999.ebuild b/media-video/ffmpeg/ffmpeg-9999.ebuild
index 0c3164a3aae7..a087dbc8b28e 100644
--- a/media-video/ffmpeg/ffmpeg-9999.ebuild
+++ b/media-video/ffmpeg/ffmpeg-9999.ebuild
@@ -90,9 +90,9 @@ FFMPEG_FLAG_MAP=(
# Same as above but for encoders, i.e. they do something only with USE=encode.
FFMPEG_ENCODER_FLAG_MAP=(
aac:libvo-aacenc amrenc:libvo-amrwbenc mp3:libmp3lame
- aacplus:libaacplus faac:libfaac nvenc:nvenc openh264:libopenh264
- snappy:libsnappy theora:libtheora twolame:libtwolame wavpack:libwavpack
- webp:libwebp x264:libx264 x265:libx265 xvid:libxvid
+ aacplus:libaacplus faac:libfaac kvazaar:libkvazaar nvenc:nvenc
+ openh264:libopenh264 snappy:libsnappy theora:libtheora twolame:libtwolame
+ wavpack:libwavpack webp:libwebp x264:libx264 x265:libx265 xvid:libxvid
)
IUSE="
@@ -165,6 +165,7 @@ RDEPEND="
aacplus? ( >=media-libs/libaacplus-2.0.2-r1[${MULTILIB_USEDEP}] )
amrenc? ( >=media-libs/vo-amrwbenc-0.1.2-r1[${MULTILIB_USEDEP}] )
faac? ( >=media-libs/faac-1.28-r3[${MULTILIB_USEDEP}] )
+ kvazaar? ( media-libs/kvazaar[${MULTILIB_USEDEP}] )
mp3? ( >=media-sound/lame-3.99.5-r1[${MULTILIB_USEDEP}] )
nvenc? ( >=media-video/nvenc-5 )
openh264? ( >=media-libs/openh264-1.4.0-r1[${MULTILIB_USEDEP}] )
diff --git a/media-video/ffmpeg/metadata.xml b/media-video/ffmpeg/metadata.xml
index d9a078ddb6c6..df168714962f 100644
--- a/media-video/ffmpeg/metadata.xml
+++ b/media-video/ffmpeg/metadata.xml
@@ -27,6 +27,7 @@
<flag name="gpl">Build GPL code. Should be enabled unless you require LGPL binaries.</flag>
<flag name="hardcoded-tables">Use pre-calculated tables rather than calculating them on the fly.</flag>
<flag name="iec61883"> Support for FireWire DV/HDV input device using <pkg>media-libs/libiec61883</pkg>.</flag>
+ <flag name="kvazaar">Enables <pkg>media-libs/kvazaar</pkg> based HEVC encoder.</flag>
<flag name="librtmp">Enables Real Time Messaging Protocol using librtmp (<pkg>media-video/rtmpdump</pkg>) in addition to FFmpeg's native implementation.</flag>
<flag name="libsoxr">Enables audio resampling through <pkg>media-libs/soxr</pkg>.</flag>
<flag name="libv4l">Uses <pkg>media-libs/libv4l</pkg> for video4linux instead of direct calls. Adds support for more devices via the userspace library.</flag>