summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-03-13 17:34:13 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-03-13 17:40:17 +0100
commit8c7a5993116dc51e8918613f75000368aaad3066 (patch)
treee65d81d7b393c96c569c13e4870de50805db48dd
parentdev-lang/boogie: bump to 3.1.3 (diff)
downloadgentoo-8c7a5993116dc51e8918613f75000368aaad3066.tar.gz
gentoo-8c7a5993116dc51e8918613f75000368aaad3066.tar.bz2
gentoo-8c7a5993116dc51e8918613f75000368aaad3066.zip
dev-cpp/cpp-httplib: disable failing tests
Closes: https://bugs.gentoo.org/924100 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild24
1 files changed, 23 insertions, 1 deletions
diff --git a/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild b/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild
index 64fb0aa6f65e..fb9e0f90ef7a 100644
--- a/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild
+++ b/dev-cpp/cpp-httplib/cpp-httplib-0.15.3.ebuild
@@ -58,6 +58,28 @@ src_configure() {
multilib_src_test() {
cp -p -R --reflink=auto "${S}/test" ./test || die
- GTEST_FILTER='-*.*_Online' emake -C test \
+ local -a failing_tests=(
+ # Disable all online tests.
+ "*.*_Online"
+
+ # Fails on musl x86:
+ ServerTest.GetRangeWithMaxLongLength
+ ServerTest.GetStreamedWithTooManyRanges
+
+ # https://github.com/yhirose/cpp-httplib/issues/1798
+ # Filed by mgorny's testing, fails on openssl >=3.2:
+ SSLClientServerTest.ClientCertPresent
+ SSLClientServerTest.ClientEncryptedCertPresent
+ SSLClientServerTest.CustomizeServerSSLCtx
+ SSLClientServerTest.MemoryClientCertPresent
+ SSLClientServerTest.MemoryClientEncryptedCertPresent
+ SSLClientServerTest.TrustDirOptional
+ )
+
+ # Little dance to please the GTEST filter (join array using ":").
+ failing_tests_str="${failing_tests[@]}"
+ failing_tests_filter="${failing_tests_str// /:}"
+
+ GTEST_FILTER="-${failing_tests_filter}" emake -C test \
CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} -I."
}