summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-08-24 10:06:47 -0400
committerMatt Turner <mattst88@gentoo.org>2022-08-24 10:08:25 -0400
commit8c82714f7c5a4803039aa05717d10143c125aaa5 (patch)
tree3ff085cb9cb0b9065782112754b0058a041a1c92
parentx11-apps/xisxwayland: Bump to EAPI=8 (diff)
downloadgentoo-8c82714f.tar.gz
gentoo-8c82714f.tar.bz2
gentoo-8c82714f.zip
x11-apps/xisxwayland: Version bump to 2
Closes: https://bugs.gentoo.org/864136 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--x11-apps/xisxwayland/Manifest1
-rw-r--r--x11-apps/xisxwayland/xisxwayland-2.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/x11-apps/xisxwayland/Manifest b/x11-apps/xisxwayland/Manifest
index b38a23609e7c..471cf332ef8b 100644
--- a/x11-apps/xisxwayland/Manifest
+++ b/x11-apps/xisxwayland/Manifest
@@ -1 +1,2 @@
DIST xisxwayland-1.tar.xz 4168 BLAKE2B a8e4a658427f5b03e3d05b25772c4f136c13be47a68619a6beab3db72a70e836e495fcbc8a19d5f9347f3336a1dc9b353f483fb75e47ebfdbb9b8409e63444f0 SHA512 9514442313cff4df0c71fed445ba0e3fe52f3c84ebbec81725a590f68cc42ea01ac96b23736a0108fe206da3aee48434c5c30d1c58905bfc75db35205c288bca
+DIST xisxwayland-2.tar.xz 5220 BLAKE2B 47bd626ad2cbeb5b0e114a4f603858c82f4f870f16de038bcadd3010f90e140fb8a3b0531e4102da7527c49bcc6bae6039aa6b42c6182da80467d5a3f040b817 SHA512 b89e19c85a5cd7e62a52e22772f80f03bfea069e31412ca11ac38174c4a2994be559e9d5fb49e6d1921b3f1b06ee71b50ede48990a1e7804a96207b08fc7827f
diff --git a/x11-apps/xisxwayland/xisxwayland-2.ebuild b/x11-apps/xisxwayland/xisxwayland-2.ebuild
new file mode 100644
index 000000000000..aaa53f42f155
--- /dev/null
+++ b/x11-apps/xisxwayland/xisxwayland-2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/app/${PN}.git"
+fi
+
+inherit ${GIT_ECLASS} meson
+
+DESCRIPTION="Tool to determine whether the X server in use is Xwayland"
+HOMEPAGE="https://gitlab.freedesktop.org/xorg/app/xisxwayland"
+if [[ ${PV} = 9999* ]]; then
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/app/${P}.tar.xz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"