summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-02-01 10:41:12 +0000
committerMarek Szuba <marecki@gentoo.org>2023-02-01 10:50:36 +0000
commit8c8ea0e9ef1b2ba74a907aa6807a03429ebfc53b (patch)
tree4ba7e12142a4166ecc3c9298906a041ab6c86b80
parentapp-emulation/qemu: Stabilize 7.2.0 arm64, #889974 (diff)
downloadgentoo-8c8ea0e9.tar.gz
gentoo-8c8ea0e9.tar.bz2
gentoo-8c8ea0e9.zip
mail-mta/msmtp: add 1.8.23
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--mail-mta/msmtp/Manifest1
-rw-r--r--mail-mta/msmtp/msmtp-1.8.23.ebuild143
2 files changed, 144 insertions, 0 deletions
diff --git a/mail-mta/msmtp/Manifest b/mail-mta/msmtp/Manifest
index 65c763f92eba..091991235a6b 100644
--- a/mail-mta/msmtp/Manifest
+++ b/mail-mta/msmtp/Manifest
@@ -1 +1,2 @@
DIST msmtp-1.8.22.tar.xz 390692 BLAKE2B 9bb6b7a7afbcc191ed2b45418d968c9b2176ec3d2d423cb9ff13b7afbb0b34978ce954f923f785281b5bca9c36d881a912d1b00c2ce102487df40228066b8e09 SHA512 13307bd8004bb7e229193b74f4e736c8462624a4aa1aedbb57421098efb2aa6b8cf1358ebc874a2db48aa6266414b4c6a1673d631356e92c1c538391533e098a
+DIST msmtp-1.8.23.tar.xz 401656 BLAKE2B 7033c7e8ad74826ab233bd9b08b8db8e17f6c9bd4cc9f6e65890099e4e12445f4665acc2faf1468f5d6f5e16a53c2479d5a0144e39d65c0521436832c1a049c5 SHA512 69675cb539fa5c78b83e90a460e8215e56b1d0fa7a18729eb058b8d51414d13b88fbcdb2092767e7e96c325a143230ac09e041ea74d068bf267e508418cf674a
diff --git a/mail-mta/msmtp/msmtp-1.8.23.ebuild b/mail-mta/msmtp/msmtp-1.8.23.ebuild
new file mode 100644
index 000000000000..7546837afc7f
--- /dev/null
+++ b/mail-mta/msmtp/msmtp-1.8.23.ebuild
@@ -0,0 +1,143 @@
+# Copyright 2004-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit fcaps
+
+DESCRIPTION="An SMTP client and SMTP plugin for mail user agents such as Mutt"
+HOMEPAGE="https://marlam.de/msmtp/"
+SRC_URI="https://marlam.de/msmtp/releases/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="daemon doc gnome-keyring +gnutls idn +mta nls sasl ssl"
+
+# fcaps.eclass unconditionally defines "filecaps" USE flag which we need for
+# USE="daemon" in order to set the caps we need.
+REQUIRED_USE="daemon? ( filecaps )"
+
+# Upstream discourages usage of openssl. See also
+# https://marlam.de/msmtp/news/openssl-discouraged/
+DEPEND="
+ gnome-keyring? ( app-crypt/libsecret )
+ idn? ( net-dns/libidn2:= )
+ nls? ( virtual/libintl )
+ sasl? ( virtual/gsasl )
+ ssl? (
+ gnutls? ( net-libs/gnutls[idn?] )
+ !gnutls? ( dev-libs/libretls:= )
+ )
+"
+
+RDEPEND="${DEPEND}
+ net-mail/mailbase
+ daemon? (
+ acct-group/msmtpd
+ acct-user/msmtpd
+ )
+ mta? (
+ !mail-mta/courier
+ !mail-mta/esmtp
+ !mail-mta/exim
+ !mail-mta/netqmail
+ !mail-mta/nullmailer
+ !mail-mta/postfix
+ !mail-mta/sendmail
+ !mail-mta/opensmtpd
+ !>=mail-mta/ssmtp-2.64-r2[mta]
+ )
+"
+
+BDEPEND="
+ doc? ( virtual/texi2dvi )
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/msmtprc*"
+
+src_prepare() {
+ # Use default Gentoo location for mail aliases
+ sed 's:/etc/aliases:/etc/mail/aliases:' \
+ -i scripts/find_alias/find_alias_for_msmtp.sh || die
+
+ default
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-gai-idn
+ $(use_enable nls)
+ $(use_with daemon msmtpd)
+ $(use_with gnome-keyring libsecret)
+ $(use_with idn libidn)
+ $(use_with sasl libgsasl)
+ $(use_with ssl tls $(usex gnutls gnutls libtls))
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ default
+
+ if use doc ; then
+ cd doc || die
+ emake html pdf
+ fi
+}
+
+src_install() {
+ default
+
+ if use daemon ; then
+ fcaps CAP_NET_BIND_SERVICE usr/bin/msmtpd
+ newinitd "${FILESDIR}"/msmtpd.init msmtpd
+ newconfd "${FILESDIR}"/msmtpd.confd msmtpd
+ fi
+
+ if use doc ; then
+ dodoc doc/msmtp.{html,pdf}
+ fi
+
+ if use mta ; then
+ dosym ../bin/msmtp /usr/sbin/sendmail
+ dosym ../bin/msmtp /usr/$(get_libdir)/sendmail
+ fi
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins scripts/vim/msmtp.vim
+
+ insinto /etc
+ newins doc/msmtprc-system.example msmtprc
+
+ src_install_contrib find_alias find_alias_for_msmtp.sh
+ src_install_contrib msmtpqueue "*.sh" "README ChangeLog"
+ src_install_contrib msmtpq "msmtpq msmtp-queue" README.msmtpq
+ src_install_contrib set_sendmail set_sendmail.sh set_sendmail.conf
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ einfo "Please edit ${EROOT}/etc/msmtprc before first use."
+ einfo "In addition, per user configuration files can be placed"
+ einfo "as '~/.msmtprc'. See the msmtprc-user.example file under"
+ einfo "/usr/share/doc/${PF}/ for an example."
+ fi
+}
+
+src_install_contrib() {
+ subdir="$1"
+ bins="$2"
+ docs="$3"
+ local dir=/usr/share/${PN}/${subdir}
+ insinto ${dir}
+ exeinto ${dir}
+ for i in ${bins} ; do
+ doexe scripts/${subdir}/${i}
+ done
+ for i in ${docs} ; do
+ newdoc scripts/${subdir}/${i} ${subdir}.${i}
+ done
+}