summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 14:30:06 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-01 14:30:06 +0100
commit8c8f22fd48a5d5befb5b517fbcdec1f03abf2e6d (patch)
treec5eb540cbbd32873dfe1a41aad04c8569271359c
parentdev-util/xfce4-dev-tools: Bump to 4.17.2 (diff)
downloadgentoo-8c8f22fd.tar.gz
gentoo-8c8f22fd.tar.bz2
gentoo-8c8f22fd.zip
xfce-base/xfce4-settings: Bump to 4.17.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.17.3.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index 4c0c6113f537..bde17ecea222 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-settings-4.16.5.tar.bz2 1498988 BLAKE2B e76a12f4d8f1a31d12beb7227ee0d4b25b3de063499e154a9854627199ba00a34a37cef72696883d20bdab620d00a402a9963aef569290f1bec06fdcc24d0c60 SHA512 1334875d8ae02a63312a3973f310138640b1a1ee80ad6665ee0f45d544092ef556b89259da613c53ab51219c9ac97fee860292133716da136792cdfd3d646e4e
DIST xfce4-settings-4.17.2.tar.bz2 1517099 BLAKE2B a8b5fc0243fd91ba48684f87676c64ca52e89baa19b3301b03f65235a3bdbc596ad100bf45ae34ac896be0a5928ea95e9c9a992ac6b022bde03327a5ac1d70fd SHA512 86231ab71bda85ab8ef7823bcf5c6aed95fd9b4abef0179923f4c9133474787c086cb22ce48db4fbbcc59fdfac6385186a41e88ce71a5f8dbd2bcb8d57575d7c
+DIST xfce4-settings-4.17.3.tar.bz2 1517554 BLAKE2B 75bb0a11ea06e38b69c60eba67d7f9eb6ff1dd835eaab04564ed53987ec5926fc671ec715ee76a96ffc52979bfbe38d35a30212b0e3a0d0d25091cc468aab78e SHA512 a932e73392e5b1d7b7aaabd8599348b8bf44cbbfa6deb54b3ee764e2e4b637c91437e33e366d5e1c333efac620f289822e9f45faf214ed5a2f53ad6a7ad59654
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.17.3.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.17.3.ebuild
new file mode 100644
index 000000000000..1408aab9e199
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.17.3.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-settings/start
+ https://gitlab.xfce.org/xfce/xfce4-settings/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.50
+ media-libs/fontconfig
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2:=
+ >=xfce-base/exo-4.15.1:=
+ >=xfce-base/libxfce4ui-4.17.0:=
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfconf-4.13:=
+ colord? ( x11-misc/colord:= )
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( >=sys-power/upower-0.9.23 )
+ xklavier? ( >=x11-libs/libxklavier-5 )
+ !<xfce-base/exo-4.15.1
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable upower upower-glib)
+ $(use_enable input_devices_libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable colord)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}