summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-11-14 10:05:48 +0100
committerLars Wendler <polynomial-c@gentoo.org>2018-11-14 10:05:48 +0100
commit8c91cd65fda9594a8c0bc8acfe19f8ed7106afe8 (patch)
tree621b392cae2ef0088c5e30b47435f10a72e700cd
parentmedia-gfx/slic3r: Add missing eclass (diff)
downloadgentoo-8c91cd65.tar.gz
gentoo-8c91cd65.tar.bz2
gentoo-8c91cd65.zip
net-libs/gsoap: Bump to version 2.8.71
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--net-libs/gsoap/Manifest1
-rw-r--r--net-libs/gsoap/gsoap-2.8.71.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/net-libs/gsoap/Manifest b/net-libs/gsoap/Manifest
index b979c4d84afa..02685fa49069 100644
--- a/net-libs/gsoap/Manifest
+++ b/net-libs/gsoap/Manifest
@@ -1,2 +1,3 @@
DIST gsoap_2.8.63.zip 32985252 BLAKE2B 6bedf06a98701dd63c13e805f865c3b84cae8c498a9ec1c4dd062e191f217c56cf9667046c5fbf0b33d94c5500e2eb4746eefa7cc909398a8ad891f2cb33e357 SHA512 1941aba9c4a7d5e57e8b8f4f2183ee3c24a9a5c3e93caedfd27a13cbc625dc06e3114f850f0dcddb87dd436a997e1157fb2c6fb20c28f1b0675e634c3d489d96
DIST gsoap_2.8.70.zip 32695627 BLAKE2B 6d803441804badf06b29cee8ca898dc864b9a0388f6f3fa58b84c1b237d77e22ab70e0cc5439915c715bdba7831b14f86d8003e1338b6184ddbfe845bb76ff75 SHA512 f7e9f85580c19bb390f1310bb47b690a5788b54c1e12c6fc0d9166039a84ae24ec5d3268cb67cd72b20e2eaa78689e175b975f07da44fd20e172a77ef37f4ae7
+DIST gsoap_2.8.71.zip 32395469 BLAKE2B 47038e70e297408f5599319b229d2bd15136d43646fe082480ae6cc29316a7f45c056e6c5859e9bfafcb24f5b10455d2209a3505c801d02299493c3b5435d06f SHA512 3e4494681b2669ea7eebaee19aa23fd31a339966f7af106258eb1bd676aff42f1069d55e6c80ae09fd60b2d48e456b0cb788d5d54829301ee62a2ef64742ddea
diff --git a/net-libs/gsoap/gsoap-2.8.71.ebuild b/net-libs/gsoap/gsoap-2.8.71.ebuild
new file mode 100644
index 000000000000..4f3a99893774
--- /dev/null
+++ b/net-libs/gsoap/gsoap-2.8.71.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_P="${PN}-2.8"
+
+DESCRIPTION="A cross-platform open source C and C++ SDK for SOAP/XML Web services"
+HOMEPAGE="http://gsoap2.sourceforge.net"
+SRC_URI="mirror://sourceforge/gsoap2/gsoap_${PV}.zip"
+
+LICENSE="GPL-2 gSOAP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc debug examples ipv6 libressl gnutls +ssl"
+
+RDEPEND="
+ sys-libs/zlib
+ gnutls? ( net-libs/gnutls )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl )
+ )
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+"
+
+PATCHES=(
+ # Fix Pre-ISO headers
+ "${FILESDIR}/${PN}-2.7.10-fedora-install_soapcpp2_wsdl2h_aux.patch"
+
+ # enable shared libs https://bugs.gentoo.org/583398
+ "${FILESDIR}/${PN}-2.8.70-shared_libs.patch"
+
+ # Fix --enable-xlocale configure switch
+ #"${FILESDIR}/${PN}-2.8.70-xlocale_h.patch"
+
+ # Fix parallel make
+ "${FILESDIR}/${PN}-2.8.70-parallel.patch"
+)
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ # Don't include xlocale.h as it got removed in >=glibc-2.26
+ --disable-xlocale
+ $(use_enable debug)
+ $(use_enable examples samples)
+ $(usex gnutls --enable-gnutls '')
+ $(usex ipv6 --enable-ipv6 '')
+ $(usex ssl '' --disable-ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ # yes, we also install the license-file since
+ # it contains info about how to apply the licenses
+ dodoc *.txt
+
+ docinto html
+ dodoc changelog.md
+
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+
+ if use examples; then
+ rm -r gsoap/samples/Makefile* gsoap/samples/*/Makefile* gsoap/samples/*/*.o || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r gsoap/samples/*
+ fi
+
+ if use doc; then
+ docinto html
+ dodoc -r gsoap/doc/*
+ fi
+}