summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-01-02 16:33:55 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-01-02 16:41:06 +0100
commit8c9d50305560842541547d9fb5ccdaaf0d438146 (patch)
treea3cbff015a0262b7d2dfc1cd9e3941c764838a05
parentgnome-base/gconf: handle GIO modules cache update, use gnome2 eclass functions (diff)
downloadgentoo-8c9d50305560842541547d9fb5ccdaaf0d438146.tar.gz
gentoo-8c9d50305560842541547d9fb5ccdaaf0d438146.tar.bz2
gentoo-8c9d50305560842541547d9fb5ccdaaf0d438146.zip
net-libs/glib-networking: handle GIO modules cache update
Package-Manager: portage-2.2.26
-rw-r--r--net-libs/glib-networking/glib-networking-2.46.1.ebuild22
1 files changed, 21 insertions, 1 deletions
diff --git a/net-libs/glib-networking/glib-networking-2.46.1.ebuild b/net-libs/glib-networking/glib-networking-2.46.1.ebuild
index 4b0c2b67174d..6f1fc6db4329 100644
--- a/net-libs/glib-networking/glib-networking-2.46.1.ebuild
+++ b/net-libs/glib-networking/glib-networking-2.46.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -67,3 +67,23 @@ multilib_src_test() {
multilib_src_install() {
gnome2_src_install
}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}