summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-08-04 12:59:35 -0400
committerAaron Bauman <bman@gentoo.org>2020-08-16 21:36:06 -0400
commit8ca2ea74ba9d96c0ed62a498c3d3d605db395438 (patch)
treebdf740f794065563f41d56150c0f33abb8c39c40
parentdev-perl/DateTime-Format-ISO8601: Bump to version 0.140.0 (diff)
downloadgentoo-8ca2ea74ba9d96c0ed62a498c3d3d605db395438.tar.gz
gentoo-8ca2ea74ba9d96c0ed62a498c3d3d605db395438.tar.bz2
gentoo-8ca2ea74ba9d96c0ed62a498c3d3d605db395438.zip
gui-libs/wf-config: update to 0.5.0
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--gui-libs/wf-config/Manifest1
-rw-r--r--gui-libs/wf-config/wf-config-0.5.0.ebuild34
-rw-r--r--gui-libs/wf-config/wf-config-9999.ebuild3
3 files changed, 36 insertions, 2 deletions
diff --git a/gui-libs/wf-config/Manifest b/gui-libs/wf-config/Manifest
index b482e024a88d..f736b124b395 100644
--- a/gui-libs/wf-config/Manifest
+++ b/gui-libs/wf-config/Manifest
@@ -1 +1,2 @@
DIST wf-config-0.4.1.tar.xz 64752 BLAKE2B ed873ee15b860690a3ac2d8623c0af933f2892c24ff6c9a10ec090bf8e7b2787970b71869c07d5e8281417ed59a4881cf3117ecb085a6d7a1eeb8fdac7375245 SHA512 99d11dfc04e80645cc29491c9ef913015a6ad6f49f351b041b277ecc2e24f9b47fc96a22ce031e51b577fe4b31df07c448d2fafb715e8fe5118e677ccbf9abe8
+DIST wf-config-0.5.0.tar.xz 64760 BLAKE2B c1939035820794828b356371c51dbd55a73a569e3a9dcf801b4aedf61c3c0131e47040a1b05e2a8cd30ecbb57f160f702b735437dfb49051a8a6a63d95201204 SHA512 b365884195cb7fc64a1ca1d74a2d12b56e1ef0f4dd49d298a9379455f2917f2c644de2b12f5068304ca404b112490e38fbfe3111aac31d301f02f23429df87c7
diff --git a/gui-libs/wf-config/wf-config-0.5.0.ebuild b/gui-libs/wf-config/wf-config-0.5.0.ebuild
new file mode 100644
index 000000000000..b100b1d861f4
--- /dev/null
+++ b/gui-libs/wf-config/wf-config-0.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="library for managing wayfire configuration files"
+HOMEPAGE="https://github.com/WayfireWM/wf-config"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-config.git"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-config/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="
+ dev-libs/libevdev
+ dev-libs/libxml2
+ >=gui-libs/wlroots-0.11.0
+ media-libs/glm
+"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="
+ dev-libs/wayland-protocols
+ virtual/pkgconfig
+"
diff --git a/gui-libs/wf-config/wf-config-9999.ebuild b/gui-libs/wf-config/wf-config-9999.ebuild
index 93cc2eacb2c5..b100b1d861f4 100644
--- a/gui-libs/wf-config/wf-config-9999.ebuild
+++ b/gui-libs/wf-config/wf-config-9999.ebuild
@@ -22,14 +22,13 @@ SLOT="0"
DEPEND="
dev-libs/libevdev
dev-libs/libxml2
- ~gui-libs/wlroots-9999
+ >=gui-libs/wlroots-0.11.0
media-libs/glm
"
RDEPEND="${DEPEND}"
BDEPEND="
- ${DEPEND}
dev-libs/wayland-protocols
virtual/pkgconfig
"