summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-24 07:15:46 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-24 08:04:06 +0100
commit8cb0508dfb421119927fc768fa771ddad1ef2092 (patch)
tree98f3131f4d239ab034272a2dfd97ce418fae8004
parentdev-python/boto3: Bump to 1.26.55 (diff)
downloadgentoo-8cb0508d.tar.gz
gentoo-8cb0508d.tar.bz2
gentoo-8cb0508d.zip
app-admin/awscli: Bump to 1.27.55
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.27.55.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 1ebf52b4b577..9dbbb5e79e4b 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.27.50.gh.tar.gz 2347235 BLAKE2B cacfe2c8d4fce7de6452a02fa8bcbcde5
DIST aws-cli-1.27.52.gh.tar.gz 2347819 BLAKE2B 1d6c26a9ede3c9cff28a66f7582a84a57dbacfaefce71b8465100abc4822a0fa1e01bf53068895901d5784fcbeb57f74fef9e872d3e145f56582edae920564ca SHA512 00b08ed90e2d67db3e091f49296f4d83b04c5a504373a613f5bf411fb17b5a1d2b7fc8612a8ff748c87dc3debe2b985c6ac2c3226683651a31d4f35d27b7c826
DIST aws-cli-1.27.53.gh.tar.gz 2349368 BLAKE2B ddae75809b9eb2e8ff5f80cdb4d5730254866dc025c178ebcf76971e53fd5d5fecbf30e20717f4a126cb19624acd961e8c005a0ced118989b062666c8ab2d346 SHA512 8eddc6f801e7e7f8600f6cdde3db28e670fdc83e6266840b507f88e0b176d790450d18f84c921af15fa12408f2f2eb16fc2498668601c3164ef1f503275303a8
DIST aws-cli-1.27.54.gh.tar.gz 2349811 BLAKE2B 08cb317ea4621273644c39c1152e1a3f8bd9f52ed8c30d7c37dfea9e986ca1597fda1dfbdea8c4043fa783f061609d6f24895997e9f9a3f27d5677c0f9e6c3de SHA512 af4783eef3c1c666b8b3c6d20f1c0177db6d4ce01645b092770cba535dad95609b4bece366355ce6d6a505ac7ab5a2e390d64fb84d6c00e402f9f8ab88db91d9
+DIST aws-cli-1.27.55.gh.tar.gz 2349668 BLAKE2B d9d0318d572e2b165a8177a1c2b76ebad042a142015bda3747038cb893b58eea6babc9e9a04547e9987dea45f505af5fe1f402a0753b780fbc779876e4a91ff8 SHA512 a6b030820c09f67f0a4df84ae0df5f622a25b0df78d203e53fb4c6f09a726a322b02f9faf9afaf9206bf38ee2c311ca2f23e07c03169d11f687ea85d45c5e225
diff --git a/app-admin/awscli/awscli-1.27.55.ebuild b/app-admin/awscli/awscli-1.27.55.ebuild
new file mode 100644
index 000000000000..62c19f3a63fb
--- /dev/null
+++ b/app-admin/awscli/awscli-1.27.55.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO
+ tests/functional/eks/test_kubeconfig.py::TestKubeconfigLoader::test_load_simple
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_env_only
+ tests/unit/customizations/eks/test_update_kubeconfig.py::TestKubeconfigSelector::test_choose_existing
+ tests/unit/customizations/eks/test_kubeconfig.py::TestKubeconfigValidator::test_valid
+ )
+
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)" --forked
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}