summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-05 07:23:36 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-05 08:07:45 +0200
commit8cb2bb59a51f1b7346607a9896a4546b1265ea73 (patch)
treef25b19f1145a87840edb81d2421d5ccd92625297
parentdev-java/icedtea-web: update homepage and upstream in metadata.xml (diff)
downloadgentoo-8cb2bb59.tar.gz
gentoo-8cb2bb59.tar.bz2
gentoo-8cb2bb59.zip
dev-python/hypothesis: Bump to 5.32.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/hypothesis/Manifest1
-rw-r--r--dev-python/hypothesis/hypothesis-5.32.0.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/hypothesis/Manifest b/dev-python/hypothesis/Manifest
index 4bb1b0a35935..e525958f48a1 100644
--- a/dev-python/hypothesis/Manifest
+++ b/dev-python/hypothesis/Manifest
@@ -9,3 +9,4 @@ DIST hypothesis-python-5.29.3.tar.gz 9070885 BLAKE2B 6e106fbc6ed6719c787083c85e3
DIST hypothesis-python-5.29.4.tar.gz 9071060 BLAKE2B 0668f3c7859fae7024c15f693b1f56ce8d02d6f3b8187d24b2d84e38e7bdb73c0824d2b02cfecc6b40bdfbbb1c91c0aa83d40848c499a97ab7e9223aaa6c78d4 SHA512 9da4b487fd3c56540a20e2fbff635704f0720f422d8a398d0accd24a1fb9517476b0d29135b9113a96e8dc98fcfc31cc53215ad82cb727be54e4e77b44d4c8e4
DIST hypothesis-python-5.30.0.tar.gz 9071239 BLAKE2B 7d46bc588d35bee187d9c19fafb41b290edb0e4b40022bfcdf502f96631aca7afe3beb6c4f27df27784ab1ef9903df7747284253906140835429e62b19eb1904 SHA512 03423b48aee71eceb84d838433351b48abf041ed1a9b617ea3e0059e8046f1cafd327e4ed4ec65c7893340602ea7d21572b3a8bbd059b27e1d0c9b867a6938b0
DIST hypothesis-python-5.30.1.tar.gz 9074506 BLAKE2B 00ee6b7244e9bb41d019234838090801f35d57e3ed0d8b1ef454d721841b1ee7833232e001b7ac1d27a9a36d727459ec1581e1f7486e57219eb23065f128254b SHA512 c81caad3e6ee28a9045947e441b28a401ae859b4f16fbfbcdf31b0b83ee30386e3f2c372ed848b14d17b1981b4a0b222b75556bd98950458d14a3cfe0d1075a9
+DIST hypothesis-python-5.32.0.tar.gz 9075649 BLAKE2B c2b375ff45e1e5ad03dc4e94d4947759ef598db5737c96d7fe7367c69a4c284d379bcfac7825a7f4e57c68c18f50164620150ead2cc8ed9e9ee1a912c896ec09 SHA512 0215a5e701f67ab5046eeaad1b158e0b85568b1680bff1a51036f67e0e77c8087fa86e1c69b9c6f6de50a65f220dcdd724ccb7d2df1e3b6d836841d193ee8b16
diff --git a/dev-python/hypothesis/hypothesis-5.32.0.ebuild b/dev-python/hypothesis/hypothesis-5.32.0.ebuild
new file mode 100644
index 000000000000..7f849fbed63c
--- /dev/null
+++ b/dev-python/hypothesis/hypothesis-5.32.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
+PYTHON_REQ_USE="threads(+),sqlite"
+
+inherit distutils-r1 eutils multiprocessing
+
+DESCRIPTION="A library for property based testing"
+HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
+SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
+S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~riscv ~x86"
+IUSE="cli test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
+ cli? (
+ $(python_gen_cond_dep '
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ ' python3_{6..9})
+ )
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ >=dev-python/pytest-5.3.5[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ !!<dev-python/typing-3.7.4.1
+ )
+"
+
+python_prepare() {
+ if ! use cli || [[ ${EPYTHON} != python* ]]; then
+ sed -i -e '/console_scripts/d' setup.py || die
+ fi
+}
+
+python_test() {
+ pytest -vv tests/cover tests/pytest tests/quality \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+pkg_postinst() {
+ optfeature "datetime support" dev-python/pytz
+ optfeature "dateutil support" dev-python/python-dateutil
+ optfeature "numpy support" dev-python/numpy
+ optfeature "django support" dev-python/django dev-python/pytz
+ optfeature "pandas support" dev-python/pandas
+ optfeature "pytest support" dev-python/pytest
+}