summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-03-14 09:33:03 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-03-14 09:33:58 -0400
commit8cf5662c415e38346a01e42a73528d2163b4c8a8 (patch)
tree55376b86e1a34492b20c35a320cb6503793d4ff6
parentnet-wireless/iwd: drop 2.8-r2, 2.13, 2.15 (diff)
downloadgentoo-8cf5662c415e38346a01e42a73528d2163b4c8a8.tar.gz
gentoo-8cf5662c415e38346a01e42a73528d2163b4c8a8.tar.bz2
gentoo-8cf5662c415e38346a01e42a73528d2163b4c8a8.zip
dev-libs/simde: add 0.8.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-libs/simde/Manifest1
-rw-r--r--dev-libs/simde/simde-0.8.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-libs/simde/Manifest b/dev-libs/simde/Manifest
index 57448efc91a2..7c1f18476515 100644
--- a/dev-libs/simde/Manifest
+++ b/dev-libs/simde/Manifest
@@ -1 +1,2 @@
DIST simde-0.7.6.tar.gz 6125123 BLAKE2B 96378e81a2e2a2d797289d26b3d0c1ea72288b51094e8c5fde75ecbef34a0c1d4dc029d5974281e2f9f938b190b4a648225fcb486205cc496ba57b1ec528cee4 SHA512 de17fca563c4db6766881e1c73142ad129a57febe55fa8ea1ae780226e60a84891b13d387e75574f2722d77e4013176e3c7dfaf17bccd8682b7d3d3ec8e92a54
+DIST simde-0.8.0.tar.gz 7455442 BLAKE2B 511f609e2588cc39b45a5a3e7f93648d9651e9e3f90220947b7f559ca6281a0db9f876d0692abf24d63528bb84e0ee49da1a165a16eeb91de84639a100a6527b SHA512 b0667583565ea9e59d18a07c7a3cb46710868c9572663e314278ca2004747e337e34f6b927c9c5d29e161caba8ec0428e5299b6e878e226b9f33597a1584b91d
diff --git a/dev-libs/simde/simde-0.8.0.ebuild b/dev-libs/simde/simde-0.8.0.ebuild
new file mode 100644
index 000000000000..6859a640590a
--- /dev/null
+++ b/dev-libs/simde/simde-0.8.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Header-only library providing implementations of SIMD instruction sets"
+HOMEPAGE="https://simd-everywhere.github.io/blog/"
+SRC_URI="
+ https://github.com/simd-everywhere/simde/archive/refs/tags/v${PV/_/-}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.6-musl.patch
+)
+
+src_configure() {
+ # *FLAGS are only used for tests (nothing that is installed), and
+ # upstream tests with specific *FLAGS and is otherwise flaky with
+ # -march=native, -mno-*, and such -- unset to be spared headaches.
+ unset {C,CPP,CXX,LD}FLAGS
+
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ if use x86; then
+ # https://github.com/simd-everywhere/simde/issues/867 (bug #926706)
+ meson_src_test $(meson_src_test --list | grep -Ev '(dbsad|fpclass)')
+ else
+ meson_src_test
+ fi
+}