summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2019-01-02 01:43:54 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-03 23:56:59 +0100
commit8cf95ddbd3247fb630942645068072c687fbbd61 (patch)
treeeb5cecdd8b56861df3807f805babee411ed56c04
parentdev-java/icedtea: update metadata.xml (diff)
downloadgentoo-8cf95ddb.tar.gz
gentoo-8cf95ddb.tar.bz2
gentoo-8cf95ddb.zip
dev-python/flask-api: verbump to 1.1
Package-Manager: Portage-2.3.53, Repoman-2.3.12 Signed-off-by: David Roman <davidroman96@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/10722 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/flask-api/Manifest1
-rw-r--r--dev-python/flask-api/flask-api-1.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/flask-api/Manifest b/dev-python/flask-api/Manifest
index 4e074089118b..dffd2b7e19cb 100644
--- a/dev-python/flask-api/Manifest
+++ b/dev-python/flask-api/Manifest
@@ -1 +1,2 @@
DIST flask-api-1.0.tar.gz 180000 BLAKE2B 113bc6a3ba9f548e61ab6c1822491d91f8562c7809929bcd2b0ecc4160a2358532d5da398b7c876cf5e4f3d9dd03bc159da6a1f24621af1e07bc9d9680b87d7f SHA512 425669e54b9f5dbf548acdb9fc2c3c661b8cfc4631d7677f20a838729584c4f970f9fbd47621e5b3155124637f5b8f4b5cb51bc402f7f406108882d46e4908de
+DIST flask-api-1.1.tar.gz 235042 BLAKE2B b3c7e476c8ef1fa21f7e60aa1fb87ef5b40708ea96332ca0290d9355552bc5c195914da769b39ace1d34864c32989cf7f9856d070b1e6b690a6c1f60b495cabc SHA512 52bb983bf9a0f906f37b645ff907eaa6ee3bc557b51f8935817963f3d66d99689eeba6a3e17711974663ad5ede267f9c85eb1d11f27597fe63806dc9f9e7ea22
diff --git a/dev-python/flask-api/flask-api-1.1.ebuild b/dev-python/flask-api/flask-api-1.1.ebuild
new file mode 100644
index 000000000000..920cdeb20047
--- /dev/null
+++ b/dev-python/flask-api/flask-api-1.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browsable web APIs for Flask"
+HOMEPAGE="https://github.com/flask-api/flask-api"
+# pypi mirror don't have docs folder
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/markdown[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc docs/about/* docs/api-guide/* docs/index.md
+}
+
+python_test() {
+ pytest -vv || die
+}