summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-10-02 08:58:12 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-10-02 09:09:32 +0000
commit8d05db421045f94522a6eb805d3755ef67a993fa (patch)
treecc002a4eeca47f9c11cb926779698e5ed8256706
parentdev-java/pdfbox: Clean up old. (diff)
downloadgentoo-8d05db42.tar.gz
gentoo-8d05db42.tar.bz2
gentoo-8d05db42.zip
dev-java/jpfcodegen: EAPI 5 bump.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--dev-java/jpfcodegen/jpfcodegen-0.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/jpfcodegen/jpfcodegen-0.4-r1.ebuild b/dev-java/jpfcodegen/jpfcodegen-0.4-r1.ebuild
new file mode 100644
index 000000000000..be5b3c127c4e
--- /dev/null
+++ b/dev-java/jpfcodegen/jpfcodegen-0.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Generator of classes for accessing the attributes and extensions of JPF plug-ins"
+HOMEPAGE="http://jabref.sourceforge.net/"
+
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="LGPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+CDEPEND="dev-java/velocity:0
+ dev-java/jpf:1.5"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${CDEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${CDEPEND}"
+
+# doc target is name="-javadoc" and would need a patch, on demand
+EANT_BUILD_TARGET="jars"
+EANT_GENTOO_CLASSPATH="jpf-1.5,velocity"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_newjar JPFCodeGenerator-${PV}.jar JPFCodeGenerator.jar
+ java-pkg_newjar JPFCodeGenerator-${PV}-rt.jar JPFCodeGenerator-rt.jar
+ dohtml index.html
+}