summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2017-01-31 22:38:50 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2017-02-01 14:49:06 -0800
commit8d14d3d9d83bac85ca36a0eb1372f1d440c6a06c (patch)
tree03f87a977beb8e6e4b1189e901330f43f2a87260
parentsci-calculators/units: Old. (diff)
downloadgentoo-8d14d3d9d83bac85ca36a0eb1372f1d440c6a06c.tar.gz
gentoo-8d14d3d9d83bac85ca36a0eb1372f1d440c6a06c.tar.bz2
gentoo-8d14d3d9d83bac85ca36a0eb1372f1d440c6a06c.zip
sys-auth/oath-toolkit: Update to version 2.6.2
(cherry picked from commit c3879f88f49d45bb548681b4d90b683bb7394d94) Package-Manager: Portage-2.3.3, Repoman-2.3.1 Fixes: https://github.com/gentoo/gentoo/pull/3758 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
-rw-r--r--sys-auth/oath-toolkit/Manifest1
-rw-r--r--sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-auth/oath-toolkit/Manifest b/sys-auth/oath-toolkit/Manifest
index d3d9253d8a9c..8465e52fab9e 100644
--- a/sys-auth/oath-toolkit/Manifest
+++ b/sys-auth/oath-toolkit/Manifest
@@ -1 +1,2 @@
DIST oath-toolkit-2.6.1.tar.gz 4238966 SHA256 9c57831907bc26eadcdf90ba1827d0bd962dd1f737362e817a1dd6d6ec036f79 SHA512 59feadbc06d11a52bf5879493227c40358fc1f4f17ec3ff92e3a313e47b92f3154396fa3ff38ef163852b32c8bfcef1f59753b614d0138478b8f7e7971f55e62 WHIRLPOOL 4c32514c265f430272d255eb6557f3b3d434c1700d4f6a5c3607808ba761d182dde679f9248b486f9e3c45d402d902bf4863b630d3415529303b2013aabe0223
+DIST oath-toolkit-2.6.2.tar.gz 4295786 SHA256 b03446fa4b549af5ebe4d35d7aba51163442d255660558cd861ebce536824aa0 SHA512 201a702a05a2e9fb3a66d04750e1a34e293342126caf02c344954a0d9fd0daafe73ca7f1fe273be129ae555a29b82b72fa2b4770ea2ad10711924e1926ec2cfb WHIRLPOOL 7321ba452070a92d60453ca3b1cb2d9c8ffff86b9fcbe48dcf8e8f00485fed809274fd2c4f6eee7cdd86d83f6f512682c3642ffe991c996140a0121c6314faf4
diff --git a/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild b/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
new file mode 100644
index 000000000000..ca54179a895b
--- /dev/null
+++ b/sys-auth/oath-toolkit/oath-toolkit-2.6.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+
+inherit pam eutils autotools
+DESCRIPTION="Toolkit for using one-time password authentication with HOTP/TOTP algorithms"
+HOMEPAGE="http://www.nongnu.org/oath-toolkit/ http://gitorious.org/oath-toolkit/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.gz"
+LICENSE="GPL-3 LGPL-2.1"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="pam pskc test"
+
+RDEPEND="
+ pam? ( virtual/pam )
+ pskc? ( dev-libs/xmlsec )"
+DEPEND="${RDEPEND}
+ test? ( dev-libs/libxml2 )
+ dev-util/gtk-doc-am"
+
+src_prepare() {
+ # These tests need git/cvs and don't reflect anything in the final app
+ sed -i -r \
+ -e '/TESTS/s,test-vc-list-files-(git|cvs).sh,,g' \
+ gl/tests/Makefile.am
+ # disable portability warnings, caused by gtk-doc.make
+ sed -i \
+ -e '/AM_INIT_AUTOMAKE/ s:-Wall:\0 -Wno-portability:' \
+ {liboath,libpskc}/configure.ac
+ eautoreconf
+ default
+}
+
+src_configure() {
+ econf \
+ $(use_enable test xmltest ) \
+ $(use_enable pam) \
+ $(use_with pam pam-dir $(getpam_mod_dir)) \
+ $(use_enable pskc)
+}
+
+src_install() {
+ default
+ if use pam; then
+ newdoc pam_oath/README README.pam
+ fi
+ if use pskc; then
+ doman pskctool/pskctool.1
+ fi
+}
+
+src_test() {
+ # without keep-going, it will bail out after the first testsuite failure,
+ # skipping the other testsuites. as they are mostly independant, this sucks.
+ emake --keep-going check
+ [ $? -ne 0 ] && die "At least one testsuite failed"
+}