summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-12 07:24:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-12 07:50:29 +0200
commit8d4057de7dae1f69e2ee45120addcd891d8b9ca5 (patch)
treeb1b3f6f3640db7dd8a36d0c996e693f6ba902913
parentdev-python/flask-sqlalchemy: Bump to 3.1.1 (diff)
downloadgentoo-8d4057de7dae1f69e2ee45120addcd891d8b9ca5.tar.gz
gentoo-8d4057de7dae1f69e2ee45120addcd891d8b9ca5.tar.bz2
gentoo-8d4057de7dae1f69e2ee45120addcd891d8b9ca5.zip
dev-python/google-auth-httplib2: Bump to 0.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-auth-httplib2/Manifest1
-rw-r--r--dev-python/google-auth-httplib2/google-auth-httplib2-0.1.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/google-auth-httplib2/Manifest b/dev-python/google-auth-httplib2/Manifest
index f60981545e1b..f94aabbb7c8f 100644
--- a/dev-python/google-auth-httplib2/Manifest
+++ b/dev-python/google-auth-httplib2/Manifest
@@ -1 +1,2 @@
DIST google-auth-library-python-httplib2-0.1.0.gh.tar.gz 25116 BLAKE2B dbb0393bafb1bbe67b99ac0783e687271c42256c7b283422b884b86d4c8a83222392a5514b812aae683ec7f887afa4bf81307079e676f793f02eb87e52a375e5 SHA512 52b0faf70e185cb89420377a06c77e2c45f6b910b85371fc2c42fdfb06a4ebca28b476201f9d179fbaa4a8bf7b6015703d023ddd95d482113e2cdbf79fd376b5
+DIST google-auth-library-python-httplib2-0.1.1.gh.tar.gz 43818 BLAKE2B 629e370d3509c8d7b47b9192f3192b013be184df8e245cd73941d233645344f019b760e92ed2119c3b0c1e6b5db0ebf74f52f7c56bd34f8c6f61cbb41311814d SHA512 2272c7019b0f47344c45d45d88f9a9de5be410764dda5ea22271a8661856abf3b3c5d92937aa126f51c385dc91b5c79578fbb81570d7f4b636a3229ad0a95403
diff --git a/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.1.ebuild b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.1.ebuild
new file mode 100644
index 000000000000..74cd7713007c
--- /dev/null
+++ b/dev-python/google-auth-httplib2/google-auth-httplib2-0.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P="google-auth-library-python-httplib2-${PV}"
+DESCRIPTION="httplib2 Transport for Google Auth"
+HOMEPAGE="
+ https://pypi.org/project/google-auth-httplib2/
+ https://github.com/googleapis/google-auth-library-python-httplib2/
+"
+SRC_URI="
+ https://github.com/googleapis/google-auth-library-python-httplib2/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/google-auth[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-localserver[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest