summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-26 22:54:16 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-27 00:34:23 +0100
commit8d51cc507ac14c40f2e4ddd0a42776de5ddd93a9 (patch)
tree89b44619d1f7a6d55fa6bdd132cb4ee77648b543
parentnet-fs/nfs-utils: Don't build static plugins (diff)
downloadgentoo-8d51cc507ac14c40f2e4ddd0a42776de5ddd93a9.tar.gz
gentoo-8d51cc507ac14c40f2e4ddd0a42776de5ddd93a9.tar.bz2
gentoo-8d51cc507ac14c40f2e4ddd0a42776de5ddd93a9.zip
dev-python/botocore: Bump to 1.20.39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.39.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 963fcb3cfa36..254ea02a2826 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -21,4 +21,5 @@ DIST botocore-1.20.34.tar.gz 7545620 BLAKE2B 49f44aa2b4799ddf03adeb48790bcf23744
DIST botocore-1.20.35.tar.gz 7547346 BLAKE2B 7fb58d475e8e57501346916759f4e0801f7c0ff61a60a1ffded2ff16cab6ef67d72f40169990673f294fe54bcd99eedd0ad4e2cf1fba39a237a17925d6c0f123 SHA512 b5fa8478ef7849951339ccc6d06948fd4e654deea5668eb0fd82813f3c095af8d67ad0986aa630e3cf579a1f2442100481e7a69ba7933e73b9178a1c599b05f0
DIST botocore-1.20.36.tar.gz 7548154 BLAKE2B 6e96c80320cd782978b44086e02af13496ed4969c535e523552fde41dada5f21990f0eb5060cfbd229ab0524a862c547c32fb3ea5c860b69fd11ef11f94bca49 SHA512 970f40e3c9b8b8a97dfeb4e5add80758d9f63b7ffd3e757903830d3458d635fc38e44f8f497fb99c65a407c56ed4f96ea1a32f794fbcfd490ba45747148d4cea
DIST botocore-1.20.38.tar.gz 7557920 BLAKE2B 9912f48f334a76e5dd9a4ddd7f79a4e1a958bfd6cbc4ebf66ff257882b49a27be28114747479148317caeba1198c486771f23f0953d8c2840b9b108c69258cec SHA512 ed068e799314881dfbd40c1e100e7572b70d302c6b694f0759f151e0acc643dde7cdcc3e3345e2607637761595fc5fc9162a2d931d8d8dfbcac02f6421953e28
+DIST botocore-1.20.39.tar.gz 7560051 BLAKE2B 0605b39e28e494add04d0f5ca559a3c1eac0011e332445fc66b4ee6a75c38f127eead72da287fdbc6da8cdb0f5ad90d18e4c71bc6641f2fe8784a1399cfd32d1 SHA512 2de58a1b585106280d292edd2a4d2f13c3c5d7ecddc24daf5a7ab65106f42a32bb700906cc19342c600cdb99d8f2ac1b951d4de5eb7f223a1c8f910ceae764d6
DIST botocore-1.20.7.tar.gz 7458254 BLAKE2B 8b9a1edda73e2564d3a3d67c6b3542d1ec9372403cb4d88396e58dfbcb5987821f278f2757e079e1ab32e03243ed3a6d1023ecc591b965512b3af5e2d43ea7b0 SHA512 9b023a31be866a50b94017a28aca40b5fe2e720959c928a3fd93db96041f3886049717f50461222a09572c0c56c5961a4614b80e400e4fa6d8b3ff4b4ab681df
diff --git a/dev-python/botocore/botocore-1.20.39.ebuild b/dev-python/botocore/botocore-1.20.39.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.39.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}