summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2016-10-31 16:07:09 +0100
committerDavid Seifert <soap@gentoo.org>2016-11-01 09:08:46 +0100
commit8dbfdaf37bb84027994c032ee68bf3e40175e4d2 (patch)
tree579ca9c33509bd1b732e733f511d88391f7605d6
parentsys-apps/ripgrep: use custom tarball with all deps and index bundled (diff)
downloadgentoo-8dbfdaf3.tar.gz
gentoo-8dbfdaf3.tar.bz2
gentoo-8dbfdaf3.zip
dev-python/ipyparallel: Drop old
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2704 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/ipyparallel/Manifest1
-rw-r--r--dev-python/ipyparallel/ipyparallel-5.0.0.ebuild58
2 files changed, 0 insertions, 59 deletions
diff --git a/dev-python/ipyparallel/Manifest b/dev-python/ipyparallel/Manifest
index 52d732f98921..62532194357f 100644
--- a/dev-python/ipyparallel/Manifest
+++ b/dev-python/ipyparallel/Manifest
@@ -1,4 +1,3 @@
DIST ipyparallel-4.1.0.tar.gz 2271608 SHA256 c943f6b3bbabb9332336d15474969e2a7a73d5b583f9786f7b357c75e4b1709a SHA512 19fff1ea57d9fcaec6525ce6e0c72ab63ab1245e32e485174a0691d2b48d8d2512af4055b77df82c7b30a8c071e1b6c5900d37e992f82f1597492e220e83d36f WHIRLPOOL ead35bc2166af0b221e730550689b09b7bf04148abcd754039f1c511acaa182ba50b593372f3e8bc627ae40a6117f9209cac476c1905bdc780f53de10666ffe1
-DIST ipyparallel-5.0.0.tar.gz 2286751 SHA256 ffa7e2e29fdc4844b3c1721f46b42eee5a1abe5cbb851ccf79d0f4f89b9fe21a SHA512 ef04b717198246300ad1020eb7f9a65c40553a897653384bd839d5fb05409a276df41f933b0f023c0523fc6d8cebf6e2c6f8478c8be4fe4fdf386ad78b8f4418 WHIRLPOOL 677fd7fa2090b2b75c234c4802fab553105d2e3ce44ab4c390cadc56ba5ff3814005ab478906197d6a9f862e0d69901168d22cdc44c8063cf8e71fc8f8bdc449
DIST ipyparallel-5.0.1.tar.gz 2350472 SHA256 48e319c16995a697c82e72dc4e5cb977be45cb0f0cdcfc482d5e8019ea6afeb2 SHA512 b7fa4f2ec5375398a533c92f07e2ab09180e537366c36ff5a7f3245d63072006ebcffc19dda28d08d5cc2e8a9044bf9101c7eeccf2857ed4a78ddd859ce23a2c WHIRLPOOL 350f67f7f341fe83bd21fb5f84714c43a426fa0d2234a532e781d0b0e9a977e2ee455184da995f5a3fbbf8e260d776dd9ac2607ac86041b5abecf41aeb9a8a9b
DIST ipyparallel-5.1.1.tar.gz 2360986 SHA256 c46cd3bad50bbe12106257241d671ce6edb3faca2ced54ed001b8f1d579720f0 SHA512 66edfafeb6ca99b04ad08a61bbe7cbcfd9ba2689d16d19c476685d73f44ec40a4f2cde75e8394dbdc3b9e4da333afdfff8960bc9f37503aa4b28af90c63878db WHIRLPOOL eebf9c71b67c9ce129e125ca3ed7fb81f38ffb604805b861cc3239e113da52c1fb939fbf400d6c0cc7cfa29330ed60730a36447f7e74c45d788b33e6f1ac60ed
diff --git a/dev-python/ipyparallel/ipyparallel-5.0.0.ebuild b/dev-python/ipyparallel/ipyparallel-5.0.0.ebuild
deleted file mode 100644
index 8bf04a1ec2f5..000000000000
--- a/dev-python/ipyparallel/ipyparallel-5.0.0.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Interactive Parallel Computing with IPython"
-HOMEPAGE="http://ipython.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/ipython_genutils[${PYTHON_USEDEP}]
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-14.4.0[${PYTHON_USEDEP}]
- dev-python/ipykernel[${PYTHON_USEDEP}]
- !<dev-python/ipython-4.0.0[smp]
- >=dev-python/ipython-4.0.0[${PYTHON_USEDEP}]
- dev-python/jupyter_client[${PYTHON_USEDEP}]
- "
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
- "
-
-python_prepare_all() {
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- iptest ipyparallel.tests -- -vsx || die
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/build/html/. )
- distutils-r1_python_install_all
-}