summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-11-04 10:03:09 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2021-11-04 10:04:04 +0200
commit8dd1909481af4844bd735c5ab0ecdb64be37c973 (patch)
tree7bf98d19575c9ef161e0d98b864442cf29b67dc9
parentdev-python/pygresql: add github upstream metadata (diff)
downloadgentoo-8dd19094.tar.gz
gentoo-8dd19094.tar.bz2
gentoo-8dd19094.zip
dev-python/pygresql: enable tests
Closes: https://bugs.gentoo.org/798375 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/pygresql/pygresql-5.2.2.ebuild26
1 files changed, 24 insertions, 2 deletions
diff --git a/dev-python/pygresql/pygresql-5.2.2.ebuild b/dev-python/pygresql/pygresql-5.2.2.ebuild
index 578b5884f409..5a676aa5de55 100644
--- a/dev-python/pygresql/pygresql-5.2.2.ebuild
+++ b/dev-python/pygresql/pygresql-5.2.2.ebuild
@@ -13,6 +13,7 @@ MY_P="PyGreSQL-${PV}"
DESCRIPTION="A Python interface for the PostgreSQL database"
HOMEPAGE="https://pygresql.org/"
SRC_URI="mirror://pypi/P/PyGreSQL/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="POSTGRESQL"
SLOT="0"
@@ -21,8 +22,29 @@ KEYWORDS="~alpha amd64 ~hppa ~ia64 ppc ~sparc x86"
DEPEND="${POSTGRES_DEP}"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-PATCHES=( "${FILESDIR}"/${PN}-5.2-CFLAGS.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.2-CFLAGS.patch
+)
+
+distutils_enable_tests unittest
+
+src_test() {
+ local db="${T}/pgsql"
+ initdb --username=portage -D "${db}" || die
+ pg_ctl -w -D "${db}" start \
+ -o "-h '127.0.0.1' -p 5432 -k '${T}'" || die
+ psql -h "${T}" -U portage -d postgres \
+ -c "ALTER ROLE portage WITH PASSWORD 'postgres';" || die
+ createdb -h "${T}" -U portage unittest || die
+
+ cat > tests/LOCAL_PyGreSQL.py <<-EOF || die
+ dbhost = '${T}'
+ EOF
+
+ distutils-r1_src_test
+
+ pg_ctl -w -D "${db}" stop || die
+}
python_install_all() {
local DOCS=( docs/*.rst docs/community/* docs/contents/tutorial.rst )