summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-11-24 14:25:52 +0000
committerSam James <sam@gentoo.org>2020-11-24 14:36:54 +0000
commit8dd5b830e36766d0bb038728fd3b4639154763e1 (patch)
tree4959a85b7304ca0d4ef9d53c4b1fae7d997b8a25
parentdev-python/libnacl: cleanup old (diff)
downloadgentoo-8dd5b830e36766d0bb038728fd3b4639154763e1.tar.gz
gentoo-8dd5b830e36766d0bb038728fd3b4639154763e1.tar.bz2
gentoo-8dd5b830e36766d0bb038728fd3b4639154763e1.zip
dev-python/lz4: bump to 3.1.1
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/lz4-3.1.1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index ff68db44120d..74fd56f30dfc 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1 +1,2 @@
DIST lz4-3.0.2.tar.gz 152443 BLAKE2B 3bf452b5b5ee65caed13b21fd7c39f32ccdea18e6d900facf74e3271868299a2da258b2b0058efaea12a3b42006f0ad0d17004692c95be951c173fee1a1162be SHA512 c31116ee3cd70241b19bff6c59d1852d4c26ad5f0c9a56cd2ecec58e8c2751773162c7ac6a2d887e8cf537bc869ed8866929164f976849efa3ea041eacc4535a
+DIST lz4-3.1.1.tar.gz 154325 BLAKE2B 2d40728087aea735aeac4d39c415edf94f9aca83c77e4a36fe53f6f32f6c1595c0b1ad97c11f6e58cacafb95e0e12d29336d9f072d4f0d47f2d522f552a368bf SHA512 b6ddcabcb323b88eeff1fa9cb91d379d6435ab51b2b51e080138892fbce57d92c8175e2ae1ef72e8a2f95429aaa4be66a5e8cd9d4dbc5bcd6b44ec26b7df96db
diff --git a/dev-python/lz4/lz4-3.1.1.ebuild b/dev-python/lz4/lz4-3.1.1.ebuild
new file mode 100644
index 000000000000..f2e006ee00d8
--- /dev/null
+++ b/dev-python/lz4/lz4-3.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-arch/lz4"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+# known test failure: https://github.com/python-lz4/python-lz4/issues/199
+PATCHES=(
+ "${FILESDIR}/lz4-3.0.2-test-fail-skip.patch"
+)
+
+distutils_enable_tests pytest