summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Vetter <jubalh@iodoru.org>2023-12-22 16:56:22 +0000
committerSam James <sam@gentoo.org>2023-12-23 18:05:00 +0000
commit8df993dc792e775c64a77f2c958e087b90294465 (patch)
treef534944aa2e66ab5b0c47e681c2fd73deb9fee67
parentgames-puzzle/nudoku: add 3.0.0 (diff)
downloadgentoo-8df993dc792e775c64a77f2c958e087b90294465.tar.gz
gentoo-8df993dc792e775c64a77f2c958e087b90294465.tar.bz2
gentoo-8df993dc792e775c64a77f2c958e087b90294465.zip
media-gfx/panini: add 0.74.0
Signed-off-by: Michael Vetter <jubalh@iodoru.org> Closes: https://github.com/gentoo/gentoo/pull/34422 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/panini/Manifest1
-rw-r--r--media-gfx/panini/panini-0.74.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/media-gfx/panini/Manifest b/media-gfx/panini/Manifest
index 4a386db423d7..643b50d1467a 100644
--- a/media-gfx/panini/Manifest
+++ b/media-gfx/panini/Manifest
@@ -1 +1,2 @@
DIST panini-0.73.0.tar.gz 329164 BLAKE2B 1cd592d7c5cf230398a6496a27f8389375a670b1de1a0f6acdb2027884bc5059798ad86ad4deb7795402654b3eb9edf112c3c177c7c716d55a186e48e1567f1c SHA512 4c12c0af5f94079f0da8f08dd19d99fd06c16c653b21532eba01022ed5b78afdcea2a042902fd50d0ea442483699cfdf9b10fd7f4592e3bae60abd5d2dabf657
+DIST panini-0.74.0.tar.gz 329344 BLAKE2B b94f774004eeb2a1b1531d92ae69141134367c6a87665d3f83944ff38a8761a41813bc023a5ec8e61131a6e193e0bfdc10ccf7100fb0ac518619b9bf94ebeee1 SHA512 e9158040cc985f088902169a2357da1bba5bda5510acec43a8edc95f5cc8033b4f8933f2b5f1b6a651872b467abc4fc3735d1565bae8a8650abd4aa8919f27b7
diff --git a/media-gfx/panini/panini-0.74.0.ebuild b/media-gfx/panini/panini-0.74.0.ebuild
new file mode 100644
index 000000000000..aaf6d2f25332
--- /dev/null
+++ b/media-gfx/panini/panini-0.74.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop qmake-utils xdg-utils
+
+MY_P="${P/p/P}-src"
+DESCRIPTION="OpenGL-based panoramic image viewer"
+HOMEPAGE="https://github.com/lazarus-pkgs/panini"
+SRC_URI="https://github.com/lazarus-pkgs/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtopengl:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ virtual/glu
+"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+"
+
+DOCS=( NEWS {BUILD,README,USAGE}.md )
+
+src_prepare() {
+ default
+ eqmake5 ${PN}.pro
+}
+
+src_install() {
+ einstalldocs
+ dobin panini
+ domenu "${FILESDIR}"/${PN}.desktop
+ newicon ui/panini-icon-blue.jpg ${PN}.jpg
+}
+
+pkg_postinst() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_mimeinfo_database_update
+ xdg_desktop_database_update
+}