summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-09-29 21:11:04 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-09-29 21:11:04 +0300
commit8dffc88036170cb23520ef8057e580b9ba17c2c8 (patch)
tree670597455ba565f43a0b4e75c7a354107c9171a5
parentdev-python/botocore: add 1.27.82 (diff)
downloadgentoo-8dffc880.tar.gz
gentoo-8dffc880.tar.bz2
gentoo-8dffc880.zip
dev-python/boto3: add 1.24.82
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.82.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 2ab02ef581e7..1766b264c7d2 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.24.74.gh.tar.gz 537890 BLAKE2B 5aa5b9fb754b9f0a1da6d05fb8419235617fa0cf50b2759c7b725cdface764921922366a1536c49ba5e283c3af10b2b987bfb3ef48f4b20882116957e6534f59 SHA512 5acbce2c828f268ca04dc5c38d192b9578ae7a16f8144262f8cb19b5364be5c39397e725cf4daed35405d31ac70907c271305320502f88ffb1f0dcfb49f3be0f
DIST boto3-1.24.80.gh.tar.gz 539716 BLAKE2B ccbbfa84e4e2274eb0275b9b2dcc0a4a78b139007829c4e3f880909f71e404be22c4461b687596bf12675c1212c6cf5b59c4383a042f60cb7919a10581fdc612 SHA512 aa3340e4bb9ae80f02fc70cf2be49d245e3dcc941b0b682c2827c1b8bb51d02e72ab7bf561e7d39397af8ca7ead7e115766fd4fd2eca18db2c551f55afb3e3b6
DIST boto3-1.24.81.gh.tar.gz 540005 BLAKE2B 7c0425351aaa4ee854d6cb616880b653250475051f3a295686659f3c85b6c515b6e622af72f6e56f69ff23be4e4218f74cbe48f6377f0d17d321f1521ed1fe8f SHA512 a92a4d90254ecc5dd098d22c9628cf87e5d5341c7aaf8b704fbe6f6e693b7582b65179936a6745da4b14a629fb20d39b501748349e3a8640eb54f9298493f287
+DIST boto3-1.24.82.gh.tar.gz 540506 BLAKE2B 5b9c008309e7bc5ff0b79a2431d1b49c353895e698227a19557ffa56950d51b1743e096a09440d3cae94b55eada1a71e01664b3458991d5665e9678cd97fdd80 SHA512 bd1ab62bd9b4f5f641a0baf6fda8d99e2a60d1fbf1bcb670b76a8171987812feb1067964dae1b633b0e35202330f97525c1ed5bf169289b8bcdde18eb882853d
diff --git a/dev-python/boto3/boto3-1.24.82.ebuild b/dev-python/boto3/boto3-1.24.82.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.82.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}