summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-12-27 13:01:27 +0200
committerAaron Bauman <bman@gentoo.org>2019-12-29 16:44:08 -0500
commit8dffe5c2869c10321888a3e362b014e3cadf6d32 (patch)
tree81a7b16a2a8912139f0c34fa04ecdc83f2307f2b
parentdev-libs/libedit: arm64 stable (bug #704116) (diff)
downloadgentoo-8dffe5c2869c10321888a3e362b014e3cadf6d32.tar.gz
gentoo-8dffe5c2869c10321888a3e362b014e3cadf6d32.tar.bz2
gentoo-8dffe5c2869c10321888a3e362b014e3cadf6d32.zip
dev-python/fuse-python: bump v1.0.0
- add PyPy3 support - add Python3.8 support Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/14136 Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-python/fuse-python/Manifest1
-rw-r--r--dev-python/fuse-python/fuse-python-1.0.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/fuse-python/Manifest b/dev-python/fuse-python/Manifest
index e5d1161cd644..a48f6391a9c4 100644
--- a/dev-python/fuse-python/Manifest
+++ b/dev-python/fuse-python/Manifest
@@ -1,2 +1,3 @@
DIST fuse-python-0.2.1.tar.gz 57833 BLAKE2B 99da322bfbfec193d2e4dfacedfd4e08a885152d1f1ceac19f49288be642c722d7776208dfdef5019b28a03cc00432e898744345041a7d615582c34668fb47a6 SHA512 f89c738352ca23e92b5c0222dde0a13bbee4d86432e9c339080203ed5bf4f885c42a0a3a252ed485f26b569d87e68dc0d78c55d8f7b2f3ce0cbac8afb251bdaa
DIST fuse-python-0.3.1.tar.gz 45391 BLAKE2B c89d53bc99dc203cb56288ab36ebc6acfa1f5f7a21e10ff6aa12cb601a363d50b06b361ee17310c55a886592b13c789af4f5e86592b7f7af103fd56aefa6402e SHA512 88c01c1f9ca3cd9738711a621b782ec190adaf068a79fdea2c362d865c38fea73706dab48b8346b21502d6b4d404403a261f96e2570254809976a3018060e188
+DIST fuse-python-1.0.0.tar.gz 46275 BLAKE2B 109202ed60df82a1a637a02627657c27ef48e55225c099385ec4d74554912d89dfd6238922a7588ff8de27e4c700a3b3832e204455997375dc67f6ca36590ae7 SHA512 d5e91be3e43065988053390d97ca6483ce38924bf9a49f694bf911080b7e75c836224e83d09dcbc6fab8d63781b4cd3ae016d66b65b88dd53106b06f91a6ad5c
diff --git a/dev-python/fuse-python/fuse-python-1.0.0.ebuild b/dev-python/fuse-python/fuse-python-1.0.0.ebuild
new file mode 100644
index 000000000000..002e6b7797bf
--- /dev/null
+++ b/dev-python/fuse-python/fuse-python-1.0.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python FUSE bindings"
+HOMEPAGE="https://github.com/libfuse/python-fuse"
+SRC_URI="https://github.com/libfuse/python-fuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="sys-fs/fuse:0="
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/python-fuse-${PV}"