summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-29 02:11:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-29 02:11:30 +0200
commit8e0a3b6550bb33d90290f10c52d3a33966be8b5e (patch)
treef4837a9444b77c99e2dac7904bee1a57a447f195
parentpackage.mask: Mask <sys-devel/binutils-2.31.1-r4 and friends (diff)
downloadgentoo-8e0a3b65.tar.gz
gentoo-8e0a3b65.tar.bz2
gentoo-8e0a3b65.zip
dev-vcs/subversion: Provide correct path to apxs binary
Thanks-to: Martin Mokrejš <mmokrejs@gmail.com> Closes: https://bugs.gentoo.org/607832 Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--dev-vcs/subversion/subversion-1.10.4.ebuild2
-rw-r--r--dev-vcs/subversion/subversion-1.11.1.ebuild2
-rw-r--r--dev-vcs/subversion/subversion-1.12.0.ebuild2
3 files changed, 3 insertions, 3 deletions
diff --git a/dev-vcs/subversion/subversion-1.10.4.ebuild b/dev-vcs/subversion/subversion-1.10.4.ebuild
index ae74dc6cd387..8e5430c0aa33 100644
--- a/dev-vcs/subversion/subversion-1.10.4.ebuild
+++ b/dev-vcs/subversion/subversion-1.10.4.ebuild
@@ -187,7 +187,7 @@ src_configure() {
local myconf=(
--libdir="${EPREFIX%/}/usr/$(get_libdir)"
$(use_with apache2 apache-libexecdir)
- $(use_with apache2 apxs "${APXS}")
+ $(use_with apache2 apxs "${EPREFIX}"/usr/bin/apxs)
$(use_with berkdb berkeley-db "db.h:${EPREFIX%/}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}")
$(use_with ctypes-python ctypesgen "${EPREFIX%/}/usr")
$(use_enable dso runtime-module-search)
diff --git a/dev-vcs/subversion/subversion-1.11.1.ebuild b/dev-vcs/subversion/subversion-1.11.1.ebuild
index 7c3f14bd27c1..bbde3cbe48f9 100644
--- a/dev-vcs/subversion/subversion-1.11.1.ebuild
+++ b/dev-vcs/subversion/subversion-1.11.1.ebuild
@@ -187,7 +187,7 @@ src_configure() {
local myconf=(
--libdir="${EPREFIX%/}/usr/$(get_libdir)"
$(use_with apache2 apache-libexecdir)
- $(use_with apache2 apxs "${APXS}")
+ $(use_with apache2 apxs "${EPREFIX}"/usr/bin/apxs)
$(use_with berkdb berkeley-db "db.h:${EPREFIX%/}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}")
$(use_with ctypes-python ctypesgen "${EPREFIX%/}/usr")
$(use_enable dso runtime-module-search)
diff --git a/dev-vcs/subversion/subversion-1.12.0.ebuild b/dev-vcs/subversion/subversion-1.12.0.ebuild
index df6ddf73f8a5..d7d1a24e7330 100644
--- a/dev-vcs/subversion/subversion-1.12.0.ebuild
+++ b/dev-vcs/subversion/subversion-1.12.0.ebuild
@@ -186,7 +186,7 @@ src_configure() {
local myconf=(
--libdir="${EPREFIX%/}/usr/$(get_libdir)"
$(use_with apache2 apache-libexecdir)
- $(use_with apache2 apxs "${APXS}")
+ $(use_with apache2 apxs "${EPREFIX}"/usr/bin/apxs)
$(use_with berkdb berkeley-db "db.h:${EPREFIX%/}/usr/include/db${SVN_BDB_VERSION}::db-${SVN_BDB_VERSION}")
$(use_with ctypes-python ctypesgen "${EPREFIX%/}/usr")
$(use_enable dso runtime-module-search)