summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-12-18 20:44:34 -0300
committerPacho Ramos <pacho@gentoo.org>2023-12-19 19:36:25 +0100
commit8e2708b2ab44c1de86ee2830bb4c68d2d4fb8edc (patch)
tree7bbb19ec5d5fe64cd56f7520fbc2e75d36583e3c
parentgui-libs/vte: Version bump to 0.74.2 (diff)
downloadgentoo-8e2708b2ab44c1de86ee2830bb4c68d2d4fb8edc.tar.gz
gentoo-8e2708b2ab44c1de86ee2830bb4c68d2d4fb8edc.tar.bz2
gentoo-8e2708b2ab44c1de86ee2830bb4c68d2d4fb8edc.zip
gui-libs/vte-common: Version bump to 0.74.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/34356 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--gui-libs/vte-common/Manifest1
-rw-r--r--gui-libs/vte-common/vte-common-0.74.2.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/gui-libs/vte-common/Manifest b/gui-libs/vte-common/Manifest
index fbab332b141f..658f76b076c1 100644
--- a/gui-libs/vte-common/Manifest
+++ b/gui-libs/vte-common/Manifest
@@ -1,3 +1,4 @@
DIST vte-0.72.2.tar.bz2 503986 BLAKE2B dbd99a1288176482ebe2cee25a1ae508694a8b47739e9c93aa8f752bf50a1f7a6efd0944430550a73224ac92248e2c4738c51eec66a643efc03616dfa7c4b110 SHA512 0510677d67474fb04c69df0038b042d379ac8e1e89b77961e403b854e4a26b2063e93bcffd75ef0a0a324df077cf2f0a4ce51afa0ad0b1e66f707393590af274
DIST vte-0.74.0.tar.bz2 505492 BLAKE2B d4f6acd817d1a950032678847c53d4cc720cf33a028078e28eee103591c480603e39eff0a8a517afddd57037ffddb25be9421487651df8d6110cf9743d8e0477 SHA512 36b1af8b41436ed00c889b99b8cab68eb1dd76c8302320d6f6703a19eed4a270faeb91d99ee906ac292da33757c6c89b6c0e54c1a224792b5424007b2879a966
DIST vte-0.74.1.tar.bz2 505521 BLAKE2B 369cf6e0d69dd2878990ae530f4d3192910f7dcdf8a9210f52ee176a42efbf1a9d771f6942ecfbffc55c8e72683368de3ca9316ecb03a3d6132cb593e6f8aa4d SHA512 405048de9b4d7dae4c5a588f2b29ad9dd3156e76c20c516050157991005350df7bd59bf1255a480e7ca4a4b657e8eed32767f085f00fadb4b23819f52983558a
+DIST vte-0.74.2.tar.bz2 505422 BLAKE2B 243eabfb26c0ec65d0b202437ae79265440256941dae4263e9d6dc9afea24d0fbbd7d421864a90b54d2ba953cd60a2b5a41aef9fb9e53396176bcc71400eef82 SHA512 203dd0f8606b8979cde01781412e0dbab3cb8857828e55f6d69ecfc2e4d58d53430aa5c61a2203e122c772ba1f6c5b739d3c03456b133580e76d511d67f3f534
diff --git a/gui-libs/vte-common/vte-common-0.74.2.ebuild b/gui-libs/vte-common/vte-common-0.74.2.ebuild
new file mode 100644
index 000000000000..6c84ecd78834
--- /dev/null
+++ b/gui-libs/vte-common/vte-common-0.74.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org meson python-any-r1
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/VTE"
+
+# Once SIXEL support ships (0.66 or later), might need xterm license (but code might be considered upgraded to LGPL-3+)
+LICENSE="LGPL-3+ GPL-3+"
+SLOT="2.91" # vte_api_version in meson.build
+IUSE="systemd"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# Upstream is hostile and refuses to upload tarballs.
+SRC_URI="https://gitlab.gnome.org/GNOME/vte/-/archive/${PV}/vte-${PV}.tar.bz2"
+
+S="${WORKDIR}/vte-${PV}"
+
+DEPEND="
+ || ( >=gui-libs/gtk-4.0.1:4 >=x11-libs/gtk+-3.24.22:3 )
+ >=x11-libs/cairo-1.0
+ >=dev-libs/fribidi-1.0.0
+ >=dev-libs/glib-2.60:2
+ >=x11-libs/pango-1.22.0
+ >=dev-libs/libpcre2-10.21
+ systemd? ( >=sys-apps/systemd-220:= )
+ sys-libs/zlib
+ x11-libs/pango
+"
+RDEPEND="
+ !<x11-libs/vte-0.70.0:2.91
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ use elibc_musl && eapply "${FILESDIR}"/${PN}-0.70.0-musl-W_EXITCODE.patch
+}
+
+src_configure() {
+ local emesonargs=(
+ -Da11y=false
+ -Ddebugg=false
+ -Ddocs=false
+ -Dgir=false
+ -Dfribidi=true # pulled in by pango anyhow
+ -Dglade=false
+ -Dgnutls=false
+ -Dgtk3=false
+ -Dgtk4=false
+ -Dicu=false
+ $(meson_use systemd _systemd)
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+src_install() {
+ exeinto /usr/libexec/
+ doexe "${BUILD_DIR}"/src/vte-urlencode-cwd
+ insinto /etc/profile.d/
+ newins "${BUILD_DIR}"/src/vte.sh vte-${SLOT}.sh
+ newins "${BUILD_DIR}"/src/vte.csh vte-${SLOT}.csh
+ if use systemd; then
+ insinto /usr/lib/systemd/user/vte-spawn-.scode.d/
+ newins "${S}"/src/vte-spawn-.scope.conf defaults.conf
+ fi
+ einstalldocs
+}