summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-07 16:00:52 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-07 16:00:52 +0100
commit8e482f8f40da312ffe4347c6c507de90dc56fdf9 (patch)
tree468b13bf50254694dde8bd78088e6389a9af74ee
parentdev-python/jsonpickle: Remove redundant versions (diff)
downloadgentoo-8e482f8f.tar.gz
gentoo-8e482f8f.tar.bz2
gentoo-8e482f8f.zip
dev-python/urwid: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/urwid/Manifest2
-rw-r--r--dev-python/urwid/files/urwid-1.1.0-sphinx.patch11
-rw-r--r--dev-python/urwid/files/urwid-1.3.1-test-vterm-EINTR.patch52
-rw-r--r--dev-python/urwid/urwid-1.3.1.ebuild58
-rw-r--r--dev-python/urwid/urwid-2.0.1.ebuild49
5 files changed, 0 insertions, 172 deletions
diff --git a/dev-python/urwid/Manifest b/dev-python/urwid/Manifest
index a1bd6c9227c1..69ca17aa1363 100644
--- a/dev-python/urwid/Manifest
+++ b/dev-python/urwid/Manifest
@@ -1,3 +1 @@
-DIST urwid-1.3.1.tar.gz 588549 BLAKE2B b2e135fa1ba60ef75f6d748c7a51e5eecef2c7fd51e19782c4901ab2715c6afc01ac709cd79c74e3da9b8671dfd021c968aaf7c3fa393e607e0ed9ac54bcbbb4 SHA512 8b505d38f3a0c04bbf527b324dc36212f2580213dd55eca61c66705d3beaac4f074c39aaa0f4f71add1fe5f3fce4c4c6dc88dd1e981b04bac6d52195d7a3f0ed
-DIST urwid-2.0.1.tar.gz 604167 BLAKE2B 0c7c289175d023bb14fca2c48eeec9e149af301827874c17d3087532f19d120ca2208306db44c5fbfd28b68f4b192f176cd46b83e915a5cbb8200e442e69fedb SHA512 99c86a26b08c624c23207ce8e587e8442bece1f522e0c788600ad5f01a4c679efff95dd947edade8b6f4adc376edca949a40c305f9d5ddaf6a0ff97f13c6da30
DIST urwid-2.1.0.tar.gz 630226 BLAKE2B 62e36080419cd4acf8c3415ce6393483244f44ffa881730ceebea71ae5535da04a7f45bd5e23fa0808a88a192c8d9d21fa2b1cf7dc3fb20485ee3280c2eeda99 SHA512 c121c0e49ab9531f67bff8740d29fc716fb8c9203e1b2ddb7257f01095e0bf976f3f2131a3b1f95a3b5368ddeea6a09b9c867ab459b91e3e9be6cba4f18ec654
diff --git a/dev-python/urwid/files/urwid-1.1.0-sphinx.patch b/dev-python/urwid/files/urwid-1.1.0-sphinx.patch
deleted file mode 100644
index 442aeea67500..000000000000
--- a/dev-python/urwid/files/urwid-1.1.0-sphinx.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- urwid-1.1.0/docs/conf.py
-+++ urwid-1.1.0/docs/conf.py
-@@ -46,7 +46,7 @@
- # The version info for the project you're documenting, acts as replacement for
- # |version| and |release|, also used in various other places throughout the
- # built documents.
--FILE_PATH = os.path.dirname(__file__).decode('utf-8')
-+FILE_PATH = os.path.dirname(__file__)
- VERSION_MODULE = os.path.abspath(os.path.join(FILE_PATH,
- '../urwid/version.py'))
- VERSION_VARS = {}
diff --git a/dev-python/urwid/files/urwid-1.3.1-test-vterm-EINTR.patch b/dev-python/urwid/files/urwid-1.3.1-test-vterm-EINTR.patch
deleted file mode 100644
index 04b6e2c949c4..000000000000
--- a/dev-python/urwid/files/urwid-1.3.1-test-vterm-EINTR.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From f68f2cf089cfd5ec45863baf59a91d5aeb0cf5c3 Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Sat, 3 Jun 2017 14:53:51 -0400
-Subject: [PATCH] test_vterm: handle EINTR when reading from pipe
-
-Fixes: https://github.com/urwid/urwid/issues/230
----
- urwid/tests/test_vterm.py | 12 ++++++++++--
- 1 file changed, 10 insertions(+), 2 deletions(-)
-
-diff --git a/urwid/tests/test_vterm.py b/urwid/tests/test_vterm.py
-index 4dadfcc..075c653 100644
---- a/urwid/tests/test_vterm.py
-+++ b/urwid/tests/test_vterm.py
-@@ -18,6 +18,7 @@
- #
- # Urwid web site: http://excess.org/urwid/
-
-+import errno
- import os
- import sys
- import unittest
-@@ -28,7 +29,6 @@
- from urwid import signals
- from urwid.compat import B
-
--
- class DummyCommand(object):
- QUITSTRING = B('|||quit|||')
-
-@@ -41,12 +41,20 @@ def __call__(self):
- stdout.write(B('\x1bc'))
-
- while True:
-- data = os.read(self.reader, 1024)
-+ data = self.read(1024)
- if self.QUITSTRING == data:
- break
- stdout.write(data)
- stdout.flush()
-
-+ def read(self, size):
-+ while True:
-+ try:
-+ return os.read(self.reader, size)
-+ except OSError as e:
-+ if e.errno != errno.EINTR:
-+ raise
-+
- def write(self, data):
- os.write(self.writer, data)
-
diff --git a/dev-python/urwid/urwid-1.3.1.ebuild b/dev-python/urwid/urwid-1.3.1.ebuild
deleted file mode 100644
index f0c427c92330..000000000000
--- a/dev-python/urwid/urwid-1.3.1.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_6 )
-PYTHON_REQ_USE="ncurses"
-
-inherit distutils-r1
-
-DESCRIPTION="Curses-based user interface library for Python"
-HOMEPAGE="http://urwid.org/ https://pypi.org/project/urwid/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.1.0-sphinx.patch"
- "${FILESDIR}/${PN}-1.3.1-test-vterm-EINTR.patch"
-)
-
-python_compile_all() {
- if use doc; then
- if python_is_python3; then
- 2to3 -nw --no-diffs docs/conf.py || die
- fi
- cd docs || die
- sphinx-build . _build/html || die
- fi
-}
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- use doc && local HTML_DOCS=( docs/_build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/urwid/urwid-2.0.1.ebuild b/dev-python/urwid/urwid-2.0.1.ebuild
deleted file mode 100644
index 776c45b2f032..000000000000
--- a/dev-python/urwid/urwid-2.0.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-PYTHON_REQ_USE="ncurses"
-
-inherit distutils-r1
-
-DESCRIPTION="Curses-based user interface library for Python"
-HOMEPAGE="http://urwid.org/ https://pypi.org/project/urwid/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
-"
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs _build/html || die
- fi
-}
-
-python_compile() {
- if ! python_is_python3; then
- local CFLAGS="${CFLAGS} -fno-strict-aliasing"
- export CFLAGS
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use examples && dodoc -r examples
- use doc && local HTML_DOCS=( _build/html/. )
-
- distutils-r1_python_install_all
-}