summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-22 13:52:13 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-22 14:15:33 +0200
commit8e57fd40c85ec6449bcca8923330a89108ec920e (patch)
tree73aaef83761f98875946441065253162b9f3f6f5
parentdev-python/pyjwt: Bump to 2.5.0 (diff)
downloadgentoo-8e57fd40.tar.gz
gentoo-8e57fd40.tar.bz2
gentoo-8e57fd40.zip
dev-python/PyPDF2: Bump to 2.10.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/PyPDF2/Manifest1
-rw-r--r--dev-python/PyPDF2/PyPDF2-2.10.9.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/PyPDF2/Manifest b/dev-python/PyPDF2/Manifest
index 1cb39d6d1666..bd1de2f51492 100644
--- a/dev-python/PyPDF2/Manifest
+++ b/dev-python/PyPDF2/Manifest
@@ -3,5 +3,6 @@ DIST PyPDF2-2.10.4.gh.tar.gz 6435008 BLAKE2B 00f4b2f65198026715186dbf1ced15e825c
DIST PyPDF2-2.10.5.gh.tar.gz 6443691 BLAKE2B 6b60ea4d1a044ee5f20718744118f5739a4271a0552960e2760c4904f57201ed8426d4cb81ce5f5d2170b84958e1b17ea3de843137e669ed7b202a49db8654c2 SHA512 cf07448b2ea4397f1bf5b2d563956bda218e9031b4396e86c2d689d518c7c2b17920771dbdf0e5ed6013dd96d957add12d3f4fbdf3a8bd3262a1fae38ae741d8
DIST PyPDF2-2.10.6.gh.tar.gz 6443648 BLAKE2B 4b5282363dea4bcec65ee6fddec787a95055ae900636b75c118fa3f2a4f5afc73807425b611c81cff6a580d4109c4df14083a1f64d7d6c373a1cd6ff9cb92fb3 SHA512 c158e6eec44429bdc103cd7f0e358289a14de92dc1d23b77f58e45a7a9851e9072fab3c8c5710f1755fdc5093380d3756db4fd12d0bdc8461cb9119d499fe012
DIST PyPDF2-2.10.8.gh.tar.gz 6444481 BLAKE2B 888cfb7977dd34c5b7d12d0fc9d2e81aaa76b837036e98537fc0829dedb6193ea4f5e9c40d2a677b036f9fc2ff09adb47afde8ad7d1e5e037613e1dda93c8faf SHA512 29bcadfb8e7fd9285ffe7b5d706cd43bec3ce9b80425232d77b834010513cd9907bf65d90e820ee1d0718be0ed384a7ff3e097c4d16d614d6cd89e272e767174
+DIST PyPDF2-2.10.9.gh.tar.gz 6448504 BLAKE2B 5508ce0b2b0d3cb00f1057a4e52dafde3ff0dbf5eaa79be46e9d20a5041b76968fd46ba74b86f15e9fb2948f2c053fd1f722f11806cfbed552d241a768d01f00 SHA512 43aec1a381e97b26145b7c8e3414a4cab33d0d03520be73b3e5e4c9565db10e9bfd764280b56f328ec5931cc41d1a6f558b29d59d0930d92de8da00b52e2f7da
DIST PyPDF2-sample-files-b6f4ff3de00745783d79f25cb8803901d1f20d28.gh.tar.gz 5522867 BLAKE2B 9a6cb3b92032f9ec697b972b1a257b2c2528d36cd4a7e40092ac6dbf0a4955c5b204b8c82d37f9bad4a19fccddf0070b095ee2f3b56de22d738ed3d8a3b555c0 SHA512 74aad38060f441ace87f6650de152a28f4a251e4f47574a8d46066857c8fbbb187cd3cd275caa198dce2c1557e90664b288f071995c2bbb9bf13a341210313e8
DIST PyPDF2-sample-files-bedcbe077c4898e1b97c6c6f81d937f5048b4630.gh.tar.gz 7198720 BLAKE2B 91d177e7329fd137322972a3a38841cb0611de7f839071fe2fa5ecff0343cbffdf6976f42f4a779f520a8a2bac2d6573c5cd65bf2f1bc68395077e6e9c7322d9 SHA512 0cdaee85f1da12cf678165f06c8d351aa0808137d25f68c07f19f1bd3c929eeb52e604041dfaa0df94665379aeb7d19a43426d724a5e6602b7e4fbe7a62e753d
diff --git a/dev-python/PyPDF2/PyPDF2-2.10.9.ebuild b/dev-python/PyPDF2/PyPDF2-2.10.9.ebuild
new file mode 100644
index 000000000000..66b49dd2cca4
--- /dev/null
+++ b/dev-python/PyPDF2/PyPDF2-2.10.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=bedcbe077c4898e1b97c6c6f81d937f5048b4630
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/PyPDF2/
+ https://github.com/py-pdf/PyPDF2/
+"
+SRC_URI="
+ https://github.com/py-pdf/PyPDF2/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+RESTRICT="test"
+# 150+ tests require network, too many to deselect
+PROPERTIES="test_network"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+BDEPEND="
+ dev-python/pillow[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+)
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${P}"/sample-files/ || die
+ fi
+}