summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2022-07-31 13:34:09 +1000
committerSam James <sam@gentoo.org>2022-07-31 05:45:09 +0100
commit8e584fd3a5ef8591c6f9df20e3d641f09822bb88 (patch)
treeb697ac4ef84a95b7d1f4df22834d032d008bb901
parentdev-haskell/test-framework: drop 0.8.2.0-r2 (diff)
downloadgentoo-8e584fd3.tar.gz
gentoo-8e584fd3.tar.bz2
gentoo-8e584fd3.zip
dev-haskell/wreq: remove broken USE flags
The bug mentioned below shows that certain USE flags are in fact broken against the latest aeson-2.0 dependency, while the package itself is compatible with aeson-2.0. This disables those USE flags as they are in fact testing flags only. Closes: https://bugs.gentoo.org/862411 Signed-off-by: Jack Todaro <solpeth@posteo.org> Closes: https://github.com/gentoo/gentoo/pull/26678 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-haskell/wreq/metadata.xml31
-rw-r--r--dev-haskell/wreq/wreq-0.5.3.3-r1.ebuild66
-rw-r--r--dev-haskell/wreq/wreq-0.5.3.3.ebuild76
3 files changed, 66 insertions, 107 deletions
diff --git a/dev-haskell/wreq/metadata.xml b/dev-haskell/wreq/metadata.xml
index 4bbbdcaa2edb..937381521944 100644
--- a/dev-haskell/wreq/metadata.xml
+++ b/dev-haskell/wreq/metadata.xml
@@ -5,35 +5,4 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
- <longdescription>
-
- A web client library that is designed for ease of use.
-
- Tutorial: &lt;http://www.serpentine.com/wreq/tutorial.html&gt;
-
- Features include:
-
- * Simple but powerful `lens`-based API
-
- * A solid test suite, and built on reliable libraries like
- http-client and lens
-
- * Session handling includes connection keep-alive and pooling, and
- cookie persistence
-
- * Automatic response body decompression
-
- * Powerful multipart form and file upload handling
-
- * Support for JSON requests and responses, including navigation of
- schema-less responses
-
- * Basic and OAuth2 bearer authentication
-
- * Early TLS support via the tls package
- </longdescription>
- <use>
- <flag name="aws">Enable AWS tests</flag>
- <flag name="httpbin">Install client</flag>
- </use>
</pkgmetadata>
diff --git a/dev-haskell/wreq/wreq-0.5.3.3-r1.ebuild b/dev-haskell/wreq/wreq-0.5.3.3-r1.ebuild
new file mode 100644
index 000000000000..4ddf3edcde72
--- /dev/null
+++ b/dev-haskell/wreq/wreq-0.5.3.3-r1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.7.2.1.9999
+#hackport: flags: -developer,-doctest,-aws,-httpbin
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An easy-to-use HTTP client library"
+HOMEPAGE="https://www.serpentine.com/wreq"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+
+RESTRICT=test # requires network
+
+RDEPEND=">=dev-haskell/aeson-0.7.0.3:=[profile?]
+ >=dev-haskell/attoparsec-0.11.1.0:=[profile?]
+ >=dev-haskell/authenticate-oauth-1.5:=[profile?]
+ dev-haskell/base16-bytestring:=[profile?]
+ dev-haskell/case-insensitive:=[profile?]
+ dev-haskell/cryptonite:=[profile?]
+ dev-haskell/hashable:=[profile?]
+ >=dev-haskell/http-client-0.6:=[profile?]
+ >=dev-haskell/http-client-tls-0.3.3:=[profile?]
+ >=dev-haskell/http-types-0.8:=[profile?]
+ >=dev-haskell/lens-4.5:=[profile?]
+ dev-haskell/lens-aeson:=[profile?]
+ dev-haskell/memory:=[profile?]
+ dev-haskell/mime-types:=[profile?]
+ >=dev-haskell/psqueues-0.2:=[profile?]
+ dev-haskell/time-locale-compat:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-lang/ghc-8.10.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.0.0
+ >=dev-haskell/cabal-doctest-1.0.2 <dev-haskell/cabal-doctest-1.1"
+# test? ( >=dev-haskell/aeson-pretty-0.8.0
+# dev-haskell/base64-bytestring
+# dev-haskell/hunit
+# dev-haskell/network-info
+# >=dev-haskell/quickcheck-2.7
+# >=dev-haskell/snap-core-1.0.0.0
+# >=dev-haskell/snap-server-0.9.4.4
+# dev-haskell/temporary
+# dev-haskell/test-framework
+# dev-haskell/test-framework-hunit
+# dev-haskell/test-framework-quickcheck2
+# dev-haskell/unix-compat
+# dev-haskell/uuid
+# dev-haskell/vector
+# dev-haskell/doctest )
+# "
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-aws \
+ --flag=-developer \
+ --flag=-doctest \
+ --flag=-httpbin
+}
diff --git a/dev-haskell/wreq/wreq-0.5.3.3.ebuild b/dev-haskell/wreq/wreq-0.5.3.3.ebuild
deleted file mode 100644
index 0c9018f69297..000000000000
--- a/dev-haskell/wreq/wreq-0.5.3.3.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-# ebuild generated by hackport 0.6.7.9999
-#hackport: flags: -developer,+doctest
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="An easy-to-use HTTP client library"
-HOMEPAGE="http://www.serpentine.com/wreq/"
-SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86"
-IUSE="aws httpbin"
-
-RESTRICT=test # needs network
-
-RDEPEND=">=dev-haskell/aeson-0.7.0.3:=[profile?]
- >=dev-haskell/attoparsec-0.11.1.0:=[profile?]
- >=dev-haskell/authenticate-oauth-1.5:=[profile?]
- dev-haskell/base16-bytestring:=[profile?]
- dev-haskell/case-insensitive:=[profile?]
- dev-haskell/cryptonite:=[profile?]
- >=dev-haskell/exceptions-0.5:=[profile?]
- dev-haskell/hashable:=[profile?]
- >=dev-haskell/http-client-0.6:=[profile?]
- >=dev-haskell/http-client-tls-0.3.3:=[profile?]
- >=dev-haskell/http-types-0.8:=[profile?]
- >=dev-haskell/lens-4.5:=[profile?]
- dev-haskell/lens-aeson:=[profile?]
- dev-haskell/memory:=[profile?]
- dev-haskell/mime-types:=[profile?]
- >=dev-haskell/psqueues-0.2:=[profile?]
- dev-haskell/text:=[profile?]
- dev-haskell/time-locale-compat:=[profile?]
- dev-haskell/unordered-containers:=[profile?]
- >=dev-lang/ghc-8.4.3:=
- httpbin? ( >=dev-haskell/aeson-pretty-0.8.0:=[profile?]
- dev-haskell/base64-bytestring:=[profile?]
- >=dev-haskell/snap-core-1.0.0.0:=[profile?]
- >=dev-haskell/snap-server-0.9.4.4:=[profile?]
- dev-haskell/unix-compat:=[profile?]
- dev-haskell/uuid:=[profile?] )
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-2.2.0.1
- >=dev-haskell/cabal-doctest-1.0.2 <dev-haskell/cabal-doctest-1.1
- test? ( dev-haskell/doctest
- dev-haskell/hunit
- dev-haskell/network-info
- >=dev-haskell/quickcheck-2.7
- dev-haskell/temporary
- dev-haskell/test-framework
- dev-haskell/test-framework-hunit
- dev-haskell/test-framework-quickcheck2
- dev-haskell/vector
- !httpbin? ( >=dev-haskell/aeson-pretty-0.8.0
- dev-haskell/base64-bytestring
- >=dev-haskell/snap-core-1.0.0.0
- >=dev-haskell/snap-server-0.9.4.4
- dev-haskell/unix-compat
- dev-haskell/uuid ) )
-"
-
-src_configure() {
- haskell-cabal_src_configure \
- $(cabal_flag aws aws) \
- --flag=-developer \
- --flag=doctest \
- $(cabal_flag httpbin httpbin)
-}