summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-25 10:44:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-25 12:05:35 +0100
commit8e5fadc4dd6870249681858dd743498896a51231 (patch)
treec10485ec98419ebdd2d7a1aa200f8f3239a6748e
parentdev-python/rebulk: Enable py3.7 (diff)
downloadgentoo-8e5fadc4dd6870249681858dd743498896a51231.tar.gz
gentoo-8e5fadc4dd6870249681858dd743498896a51231.tar.bz2
gentoo-8e5fadc4dd6870249681858dd743498896a51231.zip
dev-python/rebulk: Call pytest directly
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rebulk/rebulk-0.9.0.ebuild15
1 files changed, 2 insertions, 13 deletions
diff --git a/dev-python/rebulk/rebulk-0.9.0.ebuild b/dev-python/rebulk/rebulk-0.9.0.ebuild
index 2fc79bb065de..d0df2d1455ca 100644
--- a/dev-python/rebulk/rebulk-0.9.0.ebuild
+++ b/dev-python/rebulk/rebulk-0.9.0.ebuild
@@ -14,17 +14,10 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="MIT Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- )
-"
+
+distutils_enable_tests pytest
python_prepare_all() {
# Remove base64-encoded zip archive with pytest.
@@ -35,7 +28,3 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-
-python_test() {
- esetup.py test
-}