summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-14 07:23:49 +0100
committerSam James <sam@gentoo.org>2021-10-14 07:23:49 +0100
commit8e60fd5146783f1e3949121a11ffaa4dbacfe277 (patch)
tree32d7ada6e3ceeae01b01538d974cf0adb1b990e2
parentnet-vpn/vpnc-scripts: x86 stable wrt bug #818004 (diff)
downloadgentoo-8e60fd5146783f1e3949121a11ffaa4dbacfe277.tar.gz
gentoo-8e60fd5146783f1e3949121a11ffaa4dbacfe277.tar.bz2
gentoo-8e60fd5146783f1e3949121a11ffaa4dbacfe277.zip
sci-chemistry/gromacs: fix configure with -custom-cflags
Need to default to AUTO and let it be overridden as appropriate later. Bug: https://bugs.gentoo.org/818055 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.3.ebuild3
-rw-r--r--sci-chemistry/gromacs/gromacs-2021.9999.ebuild3
-rw-r--r--sci-chemistry/gromacs/gromacs-9999.ebuild3
3 files changed, 6 insertions, 3 deletions
diff --git a/sci-chemistry/gromacs/gromacs-2021.3.ebuild b/sci-chemistry/gromacs/gromacs-2021.3.ebuild
index e77091aa53d1..2298195203df 100644
--- a/sci-chemistry/gromacs/gromacs-2021.3.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.3.ebuild
@@ -161,10 +161,11 @@ src_prepare() {
src_configure() {
local mycmakeargs_pre=( ) extra fft_opts=( )
+ local acce="AUTO"
if use custom-cflags; then
#go from slowest to fastest acceleration
- local acce="None"
+ acce="None"
if (use amd64 || use x86); then
use cpu_flags_x86_sse2 && acce="SSE2"
use cpu_flags_x86_sse4_1 && acce="SSE4.1"
diff --git a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
index ebd3a798340c..ee0586bbca72 100644
--- a/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-2021.9999.ebuild
@@ -161,10 +161,11 @@ src_prepare() {
src_configure() {
local mycmakeargs_pre=( ) extra fft_opts=( )
+ local acce="AUTO"
if use custom-cflags; then
#go from slowest to fastest acceleration
- local acce="None"
+ acce="None"
if (use amd64 || use x86); then
use cpu_flags_x86_sse2 && acce="SSE2"
use cpu_flags_x86_sse4_1 && acce="SSE4.1"
diff --git a/sci-chemistry/gromacs/gromacs-9999.ebuild b/sci-chemistry/gromacs/gromacs-9999.ebuild
index ebd3a798340c..ee0586bbca72 100644
--- a/sci-chemistry/gromacs/gromacs-9999.ebuild
+++ b/sci-chemistry/gromacs/gromacs-9999.ebuild
@@ -161,10 +161,11 @@ src_prepare() {
src_configure() {
local mycmakeargs_pre=( ) extra fft_opts=( )
+ local acce="AUTO"
if use custom-cflags; then
#go from slowest to fastest acceleration
- local acce="None"
+ acce="None"
if (use amd64 || use x86); then
use cpu_flags_x86_sse2 && acce="SSE2"
use cpu_flags_x86_sse4_1 && acce="SSE4.1"