summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-18 06:34:54 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-18 08:27:36 +0100
commit8e627bc914fdbf2d9ecc9db6ddc3936d2a54e631 (patch)
treed4292f56d755ca6c49d34ac049e4e2b0dd00bea8
parentdev-python/tox: Bump to 4.0.13 (diff)
downloadgentoo-8e627bc914fdbf2d9ecc9db6ddc3936d2a54e631.tar.gz
gentoo-8e627bc914fdbf2d9ecc9db6ddc3936d2a54e631.tar.bz2
gentoo-8e627bc914fdbf2d9ecc9db6ddc3936d2a54e631.zip
dev-python/pytz: Bump to 2022.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pytz/Manifest1
-rw-r--r--dev-python/pytz/pytz-2022.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/pytz/Manifest b/dev-python/pytz/Manifest
index 7484ee9c7869..5043342039f2 100644
--- a/dev-python/pytz/Manifest
+++ b/dev-python/pytz/Manifest
@@ -1 +1,2 @@
DIST pytz-2022.6.tar.gz 313766 BLAKE2B db52c5dab06c90f6cacda590682a8011e59a2f1155edb1147a656561b29098bcaa34e2140f260b314b360efa879e822ca76e14e637f5cb5581b43d93c12958b3 SHA512 ea0343453d011e252fba64502984e2a43ea7c7437a211025ca68a4a45178c8aaef4c2b65261434289b21166a99a1941ec9e2d9d26bb3d22a76cbaa421250131d
+DIST pytz-2022.7.tar.gz 313499 BLAKE2B 357ef0107856e02e6c7cf028661d23a36cf3997dd5399f5a89e850b1b2e5330da08c60e10c8a7126d47d1d7e52e95bd29a8d63cdefaf4fced1332602ce0bd0d0 SHA512 48bad8a88e124c0935bf307713659228100c5c38230b3ee7f0aa92e46a1a305c4cebef388208dc7090ba59f51c4816f78789a091d69541615e885a9ad61c475b
diff --git a/dev-python/pytz/pytz-2022.7.ebuild b/dev-python/pytz/pytz-2022.7.ebuild
new file mode 100644
index 000000000000..45af071f312d
--- /dev/null
+++ b/dev-python/pytz/pytz-2022.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="World timezone definitions for Python"
+HOMEPAGE="
+ https://pythonhosted.org/pytz/
+ https://launchpad.net/pytz/
+ https://pypi.org/project/pytz/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+DEPEND="
+ || (
+ >=sys-libs/timezone-data-2017a
+ sys-libs/glibc[vanilla]
+ )
+"
+RDEPEND="${DEPEND}"
+
+python_test() {
+ "${EPYTHON}" pytz/tests/test_tzinfo.py -v ||
+ die "Tests fail with ${EPYTHON}"
+}