summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-17 18:11:08 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-17 18:11:08 +0100
commit8e6f391d59f59212c60bd407018daf7baea14370 (patch)
treecb5b06f883bb645b8d7f141ef2236c261a2bad5a
parentdev-python/coloredlogs: Drop old (diff)
downloadgentoo-8e6f391d59f59212c60bd407018daf7baea14370.tar.gz
gentoo-8e6f391d59f59212c60bd407018daf7baea14370.tar.bz2
gentoo-8e6f391d59f59212c60bd407018daf7baea14370.zip
dev-python/coloredlogs: Version Bump
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
-rw-r--r--dev-python/coloredlogs/Manifest1
-rw-r--r--dev-python/coloredlogs/coloredlogs-5.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/coloredlogs/Manifest b/dev-python/coloredlogs/Manifest
index 3ffdaced806e..78b4c40a1bbf 100644
--- a/dev-python/coloredlogs/Manifest
+++ b/dev-python/coloredlogs/Manifest
@@ -1 +1,2 @@
DIST coloredlogs-3.1.4.tar.gz 23038 SHA256 c906ef520d55b94ace4f0aad8625a89fc1d324f24ed2892cc1ac5d479183a14c SHA512 0ee97d0b0e12351c006686418b09a951c3f4c04b6533437e41ffd54f9c427c2b9e5a35c486a37c54565d7cb0c4150b1656a87fed5a86f3ed08b3cd2595d59bd5 WHIRLPOOL caeb81a34e2c832a0d75e8123bb0d9d7e9071269b44e103031ab31657225f43a578f4eb10c6f5aaccce24feba08460fceb8bce9e0bba8eb873df2daa65338fa0
+DIST coloredlogs-5.0.tar.gz 24933 SHA256 612354a11acd2e1d603c24fe7be21d736c53a23ad27f244cd9e3fdb4a99661d4 SHA512 f20a18779964b0bd4d48b51b6df81a57e3918f0097108510c50d27d88386ae89bc4e6abcb6263e757148c5094aa02edb6fe8829caecae13ed4fe7596db488763 WHIRLPOOL e23012b14689125ac09d3c16dfe32823e7f792030e3be77899f6aa8bbc1c757c23f9fd739907e67ae3a24304bda036e7e690f95ccf6e7793ca75379bff11f726
diff --git a/dev-python/coloredlogs/coloredlogs-5.0.ebuild b/dev-python/coloredlogs/coloredlogs-5.0.ebuild
new file mode 100644
index 000000000000..ec7bcb061bc0
--- /dev/null
+++ b/dev-python/coloredlogs/coloredlogs-5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Colored stream handler for the logging module"
+HOMEPAGE="https://pypi.python.org/pypi/coloredlogs https://github.com/xolox/python-coloredlogs http://coloredlogs.readthedocs.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=">=dev-python/humanfriendly-1.42[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/capturer[${PYTHON_USEDEP}]
+ dev-python/verboselogs[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( README.rst )
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0-skip-cli-test.patch )
+
+python_test() {
+ # Sandbox violations
+ sed \
+ -e 's:test_system_logging:_&:g' \
+ -i ${PN}/tests.py || die
+ esetup.py test
+}