summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-08-31 13:14:37 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2019-08-31 13:16:32 +0100
commit8e7716ec178284d781029688d4083a4380c3c4ab (patch)
treebfa62f2b0b0673bb6456ffe8897dbbc2456fc823
parentapp-text/winefish: Remove last-rited pkg (diff)
downloadgentoo-8e7716ec178284d781029688d4083a4380c3c4ab.tar.gz
gentoo-8e7716ec178284d781029688d4083a4380c3c4ab.tar.bz2
gentoo-8e7716ec178284d781029688d4083a4380c3c4ab.zip
dev-embedded/sdcc: use dostrip in live ebuild as well
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-embedded/sdcc/sdcc-3.8.0-r1.ebuild2
-rw-r--r--dev-embedded/sdcc/sdcc-9999.ebuild7
2 files changed, 3 insertions, 6 deletions
diff --git a/dev-embedded/sdcc/sdcc-3.8.0-r1.ebuild b/dev-embedded/sdcc/sdcc-3.8.0-r1.ebuild
index 79c2981dc3e6..08e64f35f2be 100644
--- a/dev-embedded/sdcc/sdcc-3.8.0-r1.ebuild
+++ b/dev-embedded/sdcc/sdcc-3.8.0-r1.ebuild
@@ -129,5 +129,5 @@ src_install() {
# a bunch of archives (*.a) are built & installed by gputils
# for PIC processors, but they do not work with standard `ar`
# & `scanelf` utils and they're not for the host.
- dostrip "${D%/}"/usr/bin
+ dostrip /usr/bin
}
diff --git a/dev-embedded/sdcc/sdcc-9999.ebuild b/dev-embedded/sdcc/sdcc-9999.ebuild
index efab11532f4c..23c2e5edc149 100644
--- a/dev-embedded/sdcc/sdcc-9999.ebuild
+++ b/dev-embedded/sdcc/sdcc-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools toolchain-funcs
if [[ ${PV} == "9999" ]] ; then
@@ -129,8 +129,5 @@ src_install() {
# a bunch of archives (*.a) are built & installed by gputils
# for PIC processors, but they do not work with standard `ar`
# & `scanelf` utils and they're not for the host.
-
- # TODO: use dostrip from EAPI=7 when subversion gets EAPI=7
- # in bug #678344:
- #dostrip "${D%/}"/usr/bin
+ dostrip /usr/bin
}