summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-01 08:15:33 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-01 09:00:56 +0200
commit8e7f35cf227ecd05010c9bca29d2431342622f26 (patch)
tree6691347deb1bfb0cee228a1c35bce4a099c8ef61
parentdev-lang/zig: bump to 0.5.0 (diff)
downloadgentoo-8e7f35cf227ecd05010c9bca29d2431342622f26.tar.gz
gentoo-8e7f35cf227ecd05010c9bca29d2431342622f26.tar.bz2
gentoo-8e7f35cf227ecd05010c9bca29d2431342622f26.zip
sys-devel/clang: Fix test failure due to '.src' in path
Closes: https://bugs.gentoo.org/695412 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang/clang-9.0.0.ebuild3
-rw-r--r--sys-devel/clang/files/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch35
2 files changed, 38 insertions, 0 deletions
diff --git a/sys-devel/clang/clang-9.0.0.ebuild b/sys-devel/clang/clang-9.0.0.ebuild
index 4a4b325876a8..43b4cf171f11 100644
--- a/sys-devel/clang/clang-9.0.0.ebuild
+++ b/sys-devel/clang/clang-9.0.0.ebuild
@@ -73,6 +73,9 @@ PATCHES=(
# fix build with gcc-9.0.0
# https://bugs.llvm.org/show_bug.cgi?id=40547
"${FILESDIR}"/9.0.0/0002-Initialize-all-fields-in-ABIArgInfo.patch
+ # fix silly test failure due to '.src' in path
+ # https://bugs.llvm.org/show_bug.cgi?id=42979
+ "${FILESDIR}"/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch
)
# Multilib notes:
diff --git a/sys-devel/clang/files/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch b/sys-devel/clang/files/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch
new file mode 100644
index 000000000000..250302da8e4c
--- /dev/null
+++ b/sys-devel/clang/files/9.0.0/0003-Fix-Driver-modules.cpp-test-to-work-when-build-direc.patch
@@ -0,0 +1,35 @@
+From f18d747107de3504ceac73abc1ec351fe8f58c95 Mon Sep 17 00:00:00 2001
+From: Tom Stellard <tstellar@redhat.com>
+Date: Mon, 30 Sep 2019 23:42:17 +0000
+Subject: [PATCH] Fix Driver/modules.cpp test to work when build directory name
+ contains '.s'
+
+Reviewers: dyung, rsmith, hansw
+
+Subscribers: mati865, mgorny, cfe-commits
+
+Tags: #clang
+
+Differential Revision: https://reviews.llvm.org/D66176
+
+llvm-svn: 373275
+---
+ clang/test/Driver/modules.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/clang/test/Driver/modules.cpp b/clang/test/Driver/modules.cpp
+index 7c549c1300f..4f4e3a41400 100644
+--- a/test/Driver/modules.cpp
++++ b/test/Driver/modules.cpp
+@@ -15,7 +15,7 @@
+ // RUN: %clang -std=c++2a %t/module.pcm -S -o %t/module.pcm.o -v 2>&1 | FileCheck %s --check-prefix=CHECK-COMPILE
+ //
+ // CHECK-COMPILE: -cc1 {{.*}} {{-emit-obj|-S}}
+-// CHECK-COMPILE-SAME: -o {{.*}}.{{pcm.o|s}}
++// CHECK-COMPILE-SAME: -o {{.*}}module{{2*}}.pcm.o
+ // CHECK-COMPILE-SAME: -x pcm
+ // CHECK-COMPILE-SAME: {{.*}}.pcm
+
+--
+2.23.0
+