summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJouni Kosonen <jouni.kosonen@tukesoft.com>2020-02-16 11:23:59 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-16 14:41:31 +0100
commit8e83a436d747f99f68445746ab19f7aade4c90bb (patch)
tree82a0fc9e80dac4bfa901f5355aa1cf4bb8655f03
parentmedia-sound/frescobaldi: version bump to 3.1.1 (diff)
downloadgentoo-8e83a436d747f99f68445746ab19f7aade4c90bb.tar.gz
gentoo-8e83a436d747f99f68445746ab19f7aade4c90bb.tar.bz2
gentoo-8e83a436d747f99f68445746ab19f7aade4c90bb.zip
dev-python/python-poppler-qt5: version bump to 0.75.0
Add python3_7 support to enable same for media-sound/frescobaldi Signed-off-by: Jouni Kosonen <jouni.kosonen@tukesoft.com> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--dev-python/python-poppler-qt5/Manifest1
-rw-r--r--dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/python-poppler-qt5/Manifest b/dev-python/python-poppler-qt5/Manifest
index 80a671f29b93..c6c9d7f9319b 100644
--- a/dev-python/python-poppler-qt5/Manifest
+++ b/dev-python/python-poppler-qt5/Manifest
@@ -1 +1,2 @@
DIST python-poppler-qt5-0.24.2_p20170214.tar.gz 20676 BLAKE2B 450f1f40618686f393a21bb2f9ae25b71ab31b4270420a278c65dfdad722a7505cab50d17968400304df936f8694a7d2d5aafeac355675756ca70271f3ff666c SHA512 28fbc4584d32ae18a0545beaf2954f89da6aaa5c2d4bbb25dc36996dd5799c38c491254330c5ac12f3a97df33656f1b49bcb672207602031ff37086a08cbb1fc
+DIST python-poppler-qt5-0.75.0.tar.gz 23281 BLAKE2B 06b2b0899d2a3cfc84e623b98cc3379aa45ac9ca9267f25168cce04f2ed761fd897043376fda3386b2daff2b46850b24782cafd6aabb13a8e7d6f3920b55a02c SHA512 2f03036a2eaeb8e28875f19a813ff85a91c1e9a94301bdb736ecc50e7ececb4de2622728e6fecbf64e114435529f82b6afd23d772e2d3910ae03d5d2b5da3205
diff --git a/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
new file mode 100644
index 000000000000..d936a77a1d84
--- /dev/null
+++ b/dev-python/python-poppler-qt5/python-poppler-qt5-0.75.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1
+
+DESCRIPTION="A python binding for libpoppler-qt5"
+HOMEPAGE="https://github.com/wbsoft/python-poppler-qt5"
+SRC_URI="https://github.com/wbsoft/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/poppler[qt5]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"