summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-01 08:14:09 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-01 08:36:43 +0200
commit8e8a5b380fdfe234f160257c074d99a1b45ae43f (patch)
treeae79efd7ce83e2fd44caa1df5e16a27d43a4530d
parentdev-python/regex: Bump to 2021.9.30 (diff)
downloadgentoo-8e8a5b38.tar.gz
gentoo-8e8a5b38.tar.bz2
gentoo-8e8a5b38.zip
dev-python/tikzplotlib: Bump to 0.9.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/tikzplotlib/Manifest1
-rw-r--r--dev-python/tikzplotlib/tikzplotlib-0.9.13.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/tikzplotlib/Manifest b/dev-python/tikzplotlib/Manifest
index 2f1da02baf57..fc0bbfecb856 100644
--- a/dev-python/tikzplotlib/Manifest
+++ b/dev-python/tikzplotlib/Manifest
@@ -1,3 +1,4 @@
DIST tikzplotlib-0.9.11.gh.tar.gz 97761 BLAKE2B 95454a9181b219e99970d06a0e40d518284ff62c7b06d9cbf5b3125b11a711e67f9df1676dc1bd73a9ec632fa01786890e3eef030f8a52ffe809835e3890359c SHA512 05fa8285f4912f2593a00ec5961f4ca94964c2ff8271158c6c1e0447f1f2b54088a76192bcda4f893adc2ad78b9240742962eee1e56043777b0df145808f42ba
DIST tikzplotlib-0.9.12.gh.tar.gz 97773 BLAKE2B 85d85445e313a41ede8c2d61d8db0d92a8f4fbb0722f716845f0fff3204e603e8b21998a588137eb67bdbc4d8f31bc5bfc82e29fc803b3c54c416191b6e5310b SHA512 4754707727eda29796a49809473b840c07b2cb7de606089d79aeb05daa6ded95a3f110deffb13ca2640e44d91c43b53520d6f29b175e200862492cb986b6c574
+DIST tikzplotlib-0.9.13.gh.tar.gz 97787 BLAKE2B ef767737b8d222773f2d5e02dbf80ac8a48ea8a00077eb245e5817337805deb5b9be27e7ed76354808647ea1ed6b17d3bbca9b33799d294bd924c18b224e3621 SHA512 f9b4c46b3179626222713dd771dccfa6b0c34ff55658838aba74867c7cd5b91dddfaefdcd2c41824c9f13a795cadd6720240beaf3d504a7f735a2169c441b449
DIST tikzplotlib-0.9.9.tar.gz 591659 BLAKE2B c8ed8069387aedc154ea1541c7e4f97cd43a74c384be4810029acf2dd1de348d732c004850b3248ba6a892451afec56fc4de0c6b05c3f4edc7b72b741e46b558 SHA512 3b6bc8b23693b1817b7f8969352bfe45f81762f86d30b9329c3c57fb1897ee5965f5759e357bbe68d21b84ac3e53e5ce80ffafccfac22d9a4a36ce104d5a2966
diff --git a/dev-python/tikzplotlib/tikzplotlib-0.9.13.ebuild b/dev-python/tikzplotlib/tikzplotlib-0.9.13.ebuild
new file mode 100644
index 000000000000..ddf06a6ca882
--- /dev/null
+++ b/dev-python/tikzplotlib/tikzplotlib-0.9.13.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/tikzplotlib"
+SRC_URI="
+ https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/texlive[extra]
+ dev-python/matplotlib[latex,${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/exdown[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc dev-python/mock
+
+python_test() {
+ local -x MPLBACKEND=Agg
+ local EPYTEST_DESELECT=(
+ tests/test_barchart_errorbars.py::test
+ tests/test_colorbars.py::test
+ tests/test_fillstyle.py::test
+ )
+
+ virtx epytest
+}