summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-03-03 19:31:14 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-03 22:00:31 +0100
commit8eab089338e433dd25c279bd87e477de9b2552b9 (patch)
tree2e62dcc9877d1eb506a473f8648be4e9e76b3d2b
parentdev-python/aesara: Remove colliding bin/__init__.py file (diff)
downloadgentoo-8eab089338e433dd25c279bd87e477de9b2552b9.tar.gz
gentoo-8eab089338e433dd25c279bd87e477de9b2552b9.tar.bz2
gentoo-8eab089338e433dd25c279bd87e477de9b2552b9.zip
dev-python/theano-pymc: Add blocker against dev-python/theano
* Remove colliding __init__.py file Bug: https://bugs.gentoo.org/774072 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/theano-pymc/theano-pymc-1.1.2-r1.ebuild (renamed from dev-python/theano-pymc/theano-pymc-1.1.2.ebuild)9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-python/theano-pymc/theano-pymc-1.1.2.ebuild b/dev-python/theano-pymc/theano-pymc-1.1.2-r1.ebuild
index 3960b80d5096..4d6177238299 100644
--- a/dev-python/theano-pymc/theano-pymc-1.1.2.ebuild
+++ b/dev-python/theano-pymc/theano-pymc-1.1.2-r1.ebuild
@@ -23,7 +23,8 @@ RDEPEND="
dev-python/filelock[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]"
+ dev-python/scipy[${PYTHON_USEDEP}]
+ !dev-python/theano[${PYTHON_USEDEP}]"
BDEPEND="
test? (
dev-python/pytest-xdist[${PYTHON_USEDEP}]
@@ -55,6 +56,12 @@ python_test() {
die "Tests fail with ${EPYTHON}"
}
+# https://dev.gentoo.org/~mgorny/python-guide/concept.html#packaging-pkgutil-style-namespaces-in-gentoo
+python_install() {
+ rm "${BUILD_DIR}"/lib/bin/__init__.py || die
+ distutils-r1_python_install
+}
+
pkg_postinst() {
optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda