summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-31 14:55:59 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-31 15:06:00 +0200
commit8eb349d7185295f5b55dd0a1badf55d08e673c67 (patch)
treeb66dd0079df5a80d88de42b48b94349f4d6771c3
parentdev-python/sphinx: Bump to 7.2.5 (diff)
downloadgentoo-8eb349d7.tar.gz
gentoo-8eb349d7.tar.bz2
gentoo-8eb349d7.zip
dev-python/sqlglot: Bump to 18.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/sqlglot/Manifest1
-rw-r--r--dev-python/sqlglot/sqlglot-18.0.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/sqlglot/Manifest b/dev-python/sqlglot/Manifest
index 3a43c47f3dc9..d05869dd5218 100644
--- a/dev-python/sqlglot/Manifest
+++ b/dev-python/sqlglot/Manifest
@@ -1,2 +1,3 @@
DIST sqlglot-17.16.2.tar.gz 8562390 BLAKE2B f985f74765438c9b57a1df9ff1ad9cf43b7e81bf8c89cb328d39d0127661f5fd4153dccc6ec1fb73a8167d4e67e8a971c4f06cba7cab5796bda7726129bcf6f0 SHA512 2487f566078cf7ac84a8e3f3a70760c5f2d5b565e1479390883551531e53a69ec0ca581585b006a44529c39a21a70867082047746ec20939f2a1e1f2408aae34
DIST sqlglot-18.0.0.tar.gz 8563952 BLAKE2B 6feb815c0169c6bbf12942a162ab769d1acba205fec8df18455d582794ec609af6549adeed0d3c47f463e1635dc13cf328ae3fb8e99dc872d53ff4692e5eb63e SHA512 9686be72eb08a61b9808bdac4dafdf2e42ffddb7be563ecb48ab9ab974efc81e271dc47ecf4e87305bd244ee8ac5fe3449697b6fad68443484ede93b1eff8a0b
+DIST sqlglot-18.0.1.tar.gz 8567474 BLAKE2B 434a31e12f98ba88e4f6fe7c34dff7f69dc991257ed4f976a4f263cb40844c41ace79ec0bf4793aee73e8359ddf4d538bee6d8dea79f9e920788b3c3ee3ef8e5 SHA512 729cea4c03a5bf2b658ca2cede31454d46275bc03af946ba238f1d79c190d3a3bc62521dd6310c544469199027fb9eadc901e919a9ce5e34fa6f4eeb18ac48ad
diff --git a/dev-python/sqlglot/sqlglot-18.0.1.ebuild b/dev-python/sqlglot/sqlglot-18.0.1.ebuild
new file mode 100644
index 000000000000..368b77416b42
--- /dev/null
+++ b/dev-python/sqlglot/sqlglot-18.0.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi optfeature
+
+DESCRIPTION="An easily customizable SQL parser and transpiler"
+HOMEPAGE="
+ https://sqlglot.com/
+ https://github.com/tobymao/sqlglot/
+ https://pypi.org/project/sqlglot/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+EPYTEST_IGNORE=(
+ # Tests require pyspark or duckdb which aren't in the tree.
+ # Pandas would be a requirement normally, but it gets ignored by proxy.
+ "tests/dataframe/integration/test_dataframe.py"
+ "tests/dataframe/integration/test_grouped_data.py"
+ "tests/dataframe/integration/test_session.py"
+ "tests/test_executor.py"
+ "tests/test_optimizer.py"
+)
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "simplifying timedelta expressions" dev-python/python-dateutil
+}