summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-01-14 15:06:18 +0100
committerMichał Górny <mgorny@gentoo.org>2017-01-14 19:12:24 +0100
commit8eb754cb5cf940e5370bd11a23335418df89f81b (patch)
tree76f9dd500e8db10a85f2b3b7c60721e6f36392fb
parent dev-ml/lablgtk: ia64/sparc stable (diff)
downloadgentoo-8eb754cb5cf940e5370bd11a23335418df89f81b.tar.gz
gentoo-8eb754cb5cf940e5370bd11a23335418df89f81b.tar.bz2
gentoo-8eb754cb5cf940e5370bd11a23335418df89f81b.zip
sys-devel/llvm: Update SLOT for new scheme, use versionator
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 16e670ce14e0..93b24094081f 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -10,7 +10,7 @@ CMAKE_MIN_VERSION=3.7.0-r1
PYTHON_COMPAT=( python2_7 )
inherit check-reqs cmake-utils flag-o-matic git-r3 \
- multilib-minimal pax-utils python-any-r1 toolchain-funcs
+ multilib-minimal pax-utils python-any-r1 toolchain-funcs versionator
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
@@ -33,7 +33,7 @@ ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LICENSE="UoI-NCSA rc BSD public-domain
llvm_targets_ARM? ( LLVM-Grant )"
-SLOT="0/${PV%.*}"
+SLOT="0/$(get_major_version)"
KEYWORDS=""
IUSE="debug +doc gold libedit +libffi multitarget ncurses test
elibc_musl kernel_Darwin ${ALL_LLVM_TARGETS[*]}"
@@ -51,7 +51,7 @@ DEPEND="${RDEPEND}
( >=sys-freebsd/freebsd-lib-9.1-r10 sys-libs/libcxx )
)
|| ( >=sys-devel/binutils-2.18 >=sys-devel/binutils-apple-5.1 )
- kernel_Darwin? ( <sys-libs/libcxx-${PV%_rc*}.9999 )
+ kernel_Darwin? ( <sys-libs/libcxx-$(get_version_component_range 1-3).9999 )
doc? ( dev-python/sphinx )
gold? ( sys-libs/binutils-libs )
libffi? ( virtual/pkgconfig )