summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-03-27 10:54:00 -0400
committerNick Sarnie <sarnex@gentoo.org>2022-03-27 10:54:00 -0400
commit8eb8ed14063b1c5a5cba0799c90f5954d2769b8d (patch)
treeaf031376aa5f543b7d556b030bba2e0c1c0b1714
parentapp-emulation/vendor-reset: Fix src_compile (diff)
downloadgentoo-8eb8ed14063b1c5a5cba0799c90f5954d2769b8d.tar.gz
gentoo-8eb8ed14063b1c5a5cba0799c90f5954d2769b8d.tar.bz2
gentoo-8eb8ed14063b1c5a5cba0799c90f5954d2769b8d.zip
app-emulation/wine-vanilla: Sync with ::wine
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.5.ebuild7
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild1
2 files changed, 5 insertions, 3 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.5.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.5.ebuild
index 09120707a07b..b0d32d130e61 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.5.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.5.ebuild
@@ -35,7 +35,7 @@ SRC_URI="${SRC_URI}
LICENSE="LGPL-2.1"
SLOT="${PV}"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos elibc_glibc +fontconfig +gecko gphoto2 gssapi gstreamer kerberos ldap mingw +mono mp3 netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl test +threads +truetype udev +udisks +unwind usb v4l vkd3d vulkan +X +xcomposite xinerama"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags dos +fontconfig +gecko gphoto2 gssapi gstreamer kerberos ldap mingw +mono mp3 netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pulseaudio +realtime +run-exes samba scanner sdl selinux +ssl test +threads +truetype udev +udisks +unwind usb v4l vkd3d vulkan +X +xcomposite xinerama"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -102,6 +102,7 @@ RDEPEND="${COMMON_DEPEND}
!app-emulation/wine:0
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
gecko? ( app-emulation/wine-gecko:2.47.2[abi_x86_32?,abi_x86_64?] )
+ mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
mono? ( app-emulation/wine-mono:7.1.1 )
perl? (
dev-lang/perl
@@ -243,8 +244,8 @@ pkg_pretend() {
# Verify OSS support
if use oss; then
if ! has_version ">=media-sound/oss-4"; then
- eerror "You cannot build wine with USE=oss without having support from a"
- eerror "FreeBSD kernel or >=media-sound/oss-4 (only available through external repos)"
+ eerror "You cannot build wine with USE=oss without having support from"
+ eerror ">=media-sound/oss-4 (only available through external repos)"
eerror
die
fi
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 07745fe6e1ba..b0d32d130e61 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -102,6 +102,7 @@ RDEPEND="${COMMON_DEPEND}
!app-emulation/wine:0
dos? ( >=games-emulation/dosbox-0.74_p20160629 )
gecko? ( app-emulation/wine-gecko:2.47.2[abi_x86_32?,abi_x86_64?] )
+ mingw? ( !!>=cross-i686-w64-mingw32/binutils-2.38 !!>=cross-x86_64-w64-mingw32/binutils-2.38 )
mono? ( app-emulation/wine-mono:7.1.1 )
perl? (
dev-lang/perl