summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-04 20:36:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-04 20:46:32 +0200
commit8ebae0a41cbfaba887e1622178ac61b168e89327 (patch)
tree0a442e6bf24c055b0f9fe6056e6c583f16d99fef
parentdev-ros/clear_costmap_recovery: Bump to 1.16.2. (diff)
downloadgentoo-8ebae0a4.tar.gz
gentoo-8ebae0a4.tar.bz2
gentoo-8ebae0a4.zip
dev-ros/costmap_2d: Bump to 1.16.2.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
-rw-r--r--dev-ros/costmap_2d/Manifest1
-rw-r--r--dev-ros/costmap_2d/costmap_2d-1.16.2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-ros/costmap_2d/Manifest b/dev-ros/costmap_2d/Manifest
index 2e0595a1965d..67d0b9c053da 100644
--- a/dev-ros/costmap_2d/Manifest
+++ b/dev-ros/costmap_2d/Manifest
@@ -1 +1,2 @@
DIST navigation-1.16.1.tar.gz 336908 BLAKE2B 0f22db60352a0f50938ae18104ecad72c2e06eedeb2da8f6afe09bdc346868fcd71c90b0243c366b9fd0e7a26fef7551ab6a4febe87ab8d66af5ce3497c68770 SHA512 f6742f5afcaff2d1fc699e2695845b148bb16523e301f79577a8073fcc829541158b7c463f2e5bd9f69571f8b4042dbfacfe563de54b16193b5a31721c5f6faf
+DIST navigation-1.16.2.tar.gz 337389 BLAKE2B a21d014df02ebf8046245777bb42fe3bccaf65af4c607532c4fb72e0b2c43870d1ff1c32c882a0418363708c0fa0c74925943beca2110a5f19b77a65e0a871fc SHA512 890eb391a8a70b3b17aa870dfa79bf48199cf3dcf7a8703b0e005b22ffd404edf723d73e30a04f902f436899fe321894bf3da7610f374b1a95b247629f64256e
diff --git a/dev-ros/costmap_2d/costmap_2d-1.16.2.ebuild b/dev-ros/costmap_2d/costmap_2d-1.16.2.ebuild
new file mode 100644
index 000000000000..4a554602785b
--- /dev/null
+++ b/dev-ros/costmap_2d/costmap_2d-1.16.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/map_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Creates a 2D costmap from sensor data"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="ros_messages_cxx"
+
+RDEPEND="
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/laser_geometry
+ dev-ros/message_filters
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/voxel_grid
+
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2_sensor_msgs
+
+ dev-cpp/eigen:3
+ dev-libs/boost:=[threads]
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+ test? (
+ dev-ros/map_server
+ dev-ros/rosbag
+ dev-ros/rostest[${PYTHON_USEDEP}]
+ dev-ros/rosunit
+ )"