summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-03 18:10:32 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-03 21:03:14 +0200
commit8edc1a333c55b4fc13e06e7c490da5ab796df012 (patch)
tree5b9f0edc43b044f51225168455229cf050d10d4a
parentapp-emacs/emms: drop old 14 (diff)
downloadgentoo-8edc1a333c55b4fc13e06e7c490da5ab796df012.tar.gz
gentoo-8edc1a333c55b4fc13e06e7c490da5ab796df012.tar.bz2
gentoo-8edc1a333c55b4fc13e06e7c490da5ab796df012.zip
app-emacs/emms: bump to 16
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--app-emacs/emms/Manifest1
-rw-r--r--app-emacs/emms/emms-16.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-emacs/emms/Manifest b/app-emacs/emms/Manifest
index daf487864923..0db11637f39f 100644
--- a/app-emacs/emms/Manifest
+++ b/app-emacs/emms/Manifest
@@ -1 +1,2 @@
DIST emms-15.tar.gz 213132 BLAKE2B cd0895d46792ca19b2a245b631f67883430477b89ed3973f6de42d95e506c8474516bde10d4a057fc7f5e38730bf6a6fce3714431782d10929945190f0da6a2a SHA512 81f4a9526b1ecc9f411c3ec62706e118bc6e39ed36130a60243bce9f312fa5873bf88af5425a12f86c2bf797dcd8afc81564a8d890c9573bc45c694c55637369
+DIST emms-16.tar.gz 213445 BLAKE2B 982e10c1e3bf5f0e305f94d80a2d753f6220ac9a5b8c991ff58273c1d39cea932e51837c1238cd89b07795fb11156e5230e806fc1329f08d78d43ec06d61bbdd SHA512 d36c0d7f797442350266b3f3d2783b0ce1310f4ee86969e1dc20c21e5814b79f124db157898b28d62fcf68975f506d3bbf3792ee218ab87444b7555fcb6a6db2
diff --git a/app-emacs/emms/emms-16.ebuild b/app-emacs/emms/emms-16.ebuild
new file mode 100644
index 000000000000..036de9427036
--- /dev/null
+++ b/app-emacs/emms/emms-16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp toolchain-funcs
+
+DESCRIPTION="The Emacs Multimedia System"
+HOMEPAGE="https://www.gnu.org/software/emms/
+ https://www.emacswiki.org/emacs/EMMS"
+SRC_URI="https://git.savannah.gnu.org/cgit/emms.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-3+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="media-libs/taglib"
+BDEPEND="${RDEPEND}"
+
+# EMMS can use almost anything for playing media files therefore the dependency
+# possibilities are so broad that we refrain from setting anything explicitly
+# in DEPEND/RDEPEND.
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" all emms-print-metadata
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ exeinto /usr/bin
+ doexe src/emms-print-metadata
+
+ doinfo doc/emms.info*
+ doman emms-print-metadata.1
+ dodoc AUTHORS NEWS README THANKGNU
+}