summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-05-06 06:44:55 +0200
committerMichał Górny <mgorny@gentoo.org>2023-05-06 08:09:02 +0200
commit8ee2ab70f83228aca1ccfcfce027bd047a68939f (patch)
tree438cc9bef06b1c2b14e3c356167e892125ccda11
parentdev-ruby/sexp_processor: add 4.17.0 (diff)
downloadgentoo-8ee2ab70f83228aca1ccfcfce027bd047a68939f.tar.gz
gentoo-8ee2ab70f83228aca1ccfcfce027bd047a68939f.tar.bz2
gentoo-8ee2ab70f83228aca1ccfcfce027bd047a68939f.zip
dev-python/statsmodels: Bump to 0.14.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/statsmodels/Manifest1
-rw-r--r--dev-python/statsmodels/files/statsmodels-0.14.0-test.patch30
-rw-r--r--dev-python/statsmodels/statsmodels-0.14.0.ebuild91
3 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/statsmodels/Manifest b/dev-python/statsmodels/Manifest
index 3cb3d897e5da..3e322bed6787 100644
--- a/dev-python/statsmodels/Manifest
+++ b/dev-python/statsmodels/Manifest
@@ -1,2 +1,3 @@
DIST statsmodels-0.13.2.tar.gz 17874260 BLAKE2B 93f7a308217ba938b3cd2e11d75e8f5ad19e2d4e6ab2abbea702143129bb53e7b9be54864375dbfec805624538bc73850357eb944d6c9a4c1252cc8a7606b904 SHA512 79d8dd63f667d4019e462d93e007a5ef8e11972fe35fb4d657931d6d68f3e35d29978a865682133db12fd6742f3362c2d77dfb5735c82ae454570388dd84d59a
DIST statsmodels-0.13.5.tar.gz 18364957 BLAKE2B 8357416b015b152612aca88a9ff42b81db4d97f61b1c255bc2baf8978440cd43fa1a5301d1c60e92b3a634008c5c001c00770685864d296587ff75e37d29ff4f SHA512 9aeeea80c69f52459140179523a0155429834b2951325c9781b28f8c4cbbd0593ff1867e2212078f2b898e4da953689c2fe78183d3c7959caa874e9d758b4ea4
+DIST statsmodels-0.14.0.tar.gz 19374614 BLAKE2B b24c8c146ea9ed393da8e839e3c9a80b1ddaa6fe319204f4440b3435c756911bc1b6405544c6ab8e4370fd378ba26715da743e4d082af7774b8cefa8649d6c58 SHA512 876cc45eb4b5badee2ff859df8a45ce7c4f6ab2973d481f58c5b7906ebcdbb56a64769d5dd7a38c7b7415a4ee7cf98cf300b8c623bda9df001b982ff6844d1fd
diff --git a/dev-python/statsmodels/files/statsmodels-0.14.0-test.patch b/dev-python/statsmodels/files/statsmodels-0.14.0-test.patch
new file mode 100644
index 000000000000..db63fbdca403
--- /dev/null
+++ b/dev-python/statsmodels/files/statsmodels-0.14.0-test.patch
@@ -0,0 +1,30 @@
+From 39a33cc65573b57a5d31ac4e9393a7c1e050da22 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 6 May 2023 07:43:28 +0200
+Subject: [PATCH] TST: install missing *.csv files needed by tsa.stl tests
+
+Closes #8869
+---
+ setup.py | 1 +
+ statsmodels/tsa/stl/tests/results/__init__.py | 0
+ 2 files changed, 1 insertion(+)
+ create mode 100644 statsmodels/tsa/stl/tests/results/__init__.py
+
+diff --git a/setup.py b/setup.py
+index 69141b2bd..c2fdc532b 100644
+--- a/setup.py
++++ b/setup.py
+@@ -126,6 +126,7 @@ ADDITIONAL_PACKAGE_DATA = {
+ "statsmodels.datasets.tests": ["*.zip"],
+ "statsmodels.iolib.tests.results": ["*.dta"],
+ "statsmodels.stats.tests.results": ["*.json"],
++ "statsmodels.tsa.stl.tests.results": ["*.csv"],
+ "statsmodels.tsa.vector_ar.tests.results": ["*.npz", "*.dat"],
+ "statsmodels.stats.tests": ["*.txt"],
+ "statsmodels.stats.libqsturng": ["*.r", "*.txt", "*.dat"],
+diff --git a/statsmodels/tsa/stl/tests/results/__init__.py b/statsmodels/tsa/stl/tests/results/__init__.py
+new file mode 100644
+index 000000000..e69de29bb
+--
+2.40.1
+
diff --git a/dev-python/statsmodels/statsmodels-0.14.0.ebuild b/dev-python/statsmodels/statsmodels-0.14.0.ebuild
new file mode 100644
index 000000000000..bab0cf805802
--- /dev/null
+++ b/dev-python/statsmodels/statsmodels-0.14.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing optfeature pypi
+
+DESCRIPTION="Statistical computations and models for use with SciPy"
+HOMEPAGE="
+ https://www.statsmodels.org/stable/index.html
+ https://github.com/statsmodels/statsmodels/
+ https://pypi.org/project/statsmodels/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.3[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ ${DEPEND}
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pandas-0.25[${PYTHON_USEDEP}]
+ >=dev-python/patsy-0.5.2[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${DEPEND}
+ <dev-python/cython-3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/ipykernel' \
+ 'dev-python/jupyter-client' \
+ 'dev-python/matplotlib' \
+ 'dev-python/nbconvert' \
+ 'dev-python/numpydoc'
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${P}-test.patch"
+ )
+
+ # Prevent un-needed d'loading
+ export VARTEXFONTS="${T}"/fonts
+ export MPLCONFIGDIR="${T}"
+ printf -- 'backend : Agg\n' > "${MPLCONFIGDIR}"/matplotlibrc || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x MKL_NUM_THREADS=1
+ local -x OMP_NUM_THREADS=1
+ local EPYTEST_DESELECT=(
+ # note that test path should be without "statsmodels/" prefix
+ imputation/tests/test_mice.py::TestMICE::test_combine
+ stats/tests/test_mediation.py::test_mixedlm
+ "stats/tests/test_corrpsd.py::test_corrpsd_threshold[0]"
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ epytest statsmodels -p xdist -n "$(makeopts_jobs)"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ optfeature "Plotting functionality" "dev-python/matplotlib"
+}